Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-217

Eclipse 3.3 New Connections shows "Browser Options" without possibility to add new address

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.1
    • Fix Version/s: 1.1.0
    • Component/s: studio-connection
    • Labels:
      None
    • Environment:
      Linux Ubuntu, Java 1.6 Sun, Eclipse 3.3 Europa with some additional plugins from Red Hat developer studio

      Description

      When I click new connection from connection view (that same goes for New -> LDAP Connection) I get the part ow wizard which allows me to "You can specify additional connection parameters." Buttons back, next finish are disabled. Basicaly now way to add new connection.

      1. Screenshot-3.png
        158 kB
        Przemyslaw Rudzki
      2. Screenshot-2.png
        150 kB
        Przemyslaw Rudzki
      3. Screenshot-1.png
        135 kB
        Przemyslaw Rudzki

        Activity

        Hide
        Pierre-Arnaud Marcelot added a comment -

        Version 1.1.0 has been released.
        Closing this issue.

        Show
        Pierre-Arnaud Marcelot added a comment - Version 1.1.0 has been released. Closing this issue.
        Hide
        Pierre-Arnaud Marcelot added a comment -

        Fixed. The jars of the version 1.1 will, this time, include the previous fix.

        Show
        Pierre-Arnaud Marcelot added a comment - Fixed. The jars of the version 1.1 will, this time, include the previous fix.
        Hide
        Pierre-Arnaud Marcelot added a comment -

        Oh yeah. You're right Stefan, my bad...

        Show
        Pierre-Arnaud Marcelot added a comment - Oh yeah. You're right Stefan, my bad...
        Hide
        Stefan Seelmann added a comment -

        @PAM:
        Here is the SVN history:
        571747 Tagging the 1.0.0 version
        571961 Fixed DIRSTUDIO-180. Added dependency between connection pages.
        572683 Copied tag 1.0.0 into releases/1.0.0

        So the connection-ui plugin doesn't contain the fix.

        The reproduction of the problem is difficult because it doesn't occur on all platforms. I was able to reproduce it on Ubuntu/Sun JDK 1.5.0_12

        Show
        Stefan Seelmann added a comment - @PAM: Here is the SVN history: 571747 Tagging the 1.0.0 version 571961 Fixed DIRSTUDIO-180 . Added dependency between connection pages. 572683 Copied tag 1.0.0 into releases/1.0.0 So the connection-ui plugin doesn't contain the fix. The reproduction of the problem is difficult because it doesn't occur on all platforms. I was able to reproduce it on Ubuntu/Sun JDK 1.5.0_12
        Hide
        Pierre-Arnaud Marcelot added a comment -

        @Stefan:
        I has been fixed in 1.0.0 in fact, I don't know why the Jira issue refers to version 1.0.1.
        If you look at the SVN history, the fix for DIRSTUDIO-180 has been committed at revision 571961 and the release tag for 1.0.0 has been committed at revision 572683.

        So, the current Browser UI plugin (version 1.0.0) contains the fix for DIRSTUDIO-180.

        This makes the situation less understandable... I tried to reproduce the bug several times, but I could not.

        @Emmanuel:
        I was more talking about a 1.1.0 than a 1.0.2 version last friday.
        I'll try to see with Christine and Stefan, what's the problem here.

        Show
        Pierre-Arnaud Marcelot added a comment - @Stefan: I has been fixed in 1.0.0 in fact, I don't know why the Jira issue refers to version 1.0.1. If you look at the SVN history, the fix for DIRSTUDIO-180 has been committed at revision 571961 and the release tag for 1.0.0 has been committed at revision 572683. So, the current Browser UI plugin (version 1.0.0) contains the fix for DIRSTUDIO-180 . This makes the situation less understandable... I tried to reproduce the bug several times, but I could not. @Emmanuel: I was more talking about a 1.1.0 than a 1.0.2 version last friday. I'll try to see with Christine and Stefan, what's the problem here.
        Hide
        Emmanuel Lecharny added a comment -

        Agreed.

        Pierre-Arnaud was telling me yesturday that a 1.0.2 should be delivered soon. I see no urgency in delivering it, if there are some more bug fixes to put into it, as we have a workaround for this present bug, but in any case, it would be the good move to plan a 1.0.2 soon.

        Can you coordinate the effort with Pierre-Arnaud and Chirstine, Stefan ?

        Thanks !

        Show
        Emmanuel Lecharny added a comment - Agreed. Pierre-Arnaud was telling me yesturday that a 1.0.2 should be delivered soon. I see no urgency in delivering it, if there are some more bug fixes to put into it, as we have a workaround for this present bug, but in any case, it would be the good move to plan a 1.0.2 soon. Can you coordinate the effort with Pierre-Arnaud and Chirstine, Stefan ? Thanks !
        Hide
        Stefan Seelmann added a comment -

        Hi all,

        This is a duplicate of DIRSTUDIO-180. It should be fixed with the 1.0.1 release.

        The problem is that our 1.0.1 release contains the 1.0.0 version of the connection-ui plugin. We only added 1.0.1 of these plugins that have changed from 1.0.0 to 1.0.1. However we missed the connection-ui plugin. This problems exists in the Studio application as well as in the eclipse update site.

        My suggestion to fix this:
        We should release a 1.0.2, based on the 1.0.1 tag (http://svn.apache.org/viewvc/directory/studio/tags/1.0.1/). We don't need to change any code. We only need to deliver the 1.0.1 version of the connection-ui plugin. Therefor we must bump-up the version of all the features packages to 1.0.2. And we need to update the update site.

        Show
        Stefan Seelmann added a comment - Hi all, This is a duplicate of DIRSTUDIO-180 . It should be fixed with the 1.0.1 release. The problem is that our 1.0.1 release contains the 1.0.0 version of the connection-ui plugin. We only added 1.0.1 of these plugins that have changed from 1.0.0 to 1.0.1. However we missed the connection-ui plugin. This problems exists in the Studio application as well as in the eclipse update site. My suggestion to fix this: We should release a 1.0.2, based on the 1.0.1 tag ( http://svn.apache.org/viewvc/directory/studio/tags/1.0.1/ ). We don't need to change any code. We only need to deliver the 1.0.1 version of the connection-ui plugin. Therefor we must bump-up the version of all the features packages to 1.0.2. And we need to update the update site.
        Hide
        Przemyslaw Rudzki added a comment -

        Indeed, it works this way .

        Show
        Przemyslaw Rudzki added a comment - Indeed, it works this way .
        Hide
        Emmanuel Lecharny added a comment -

        There is a workaround : uncheck the "Get base DNs fro rootDSE" check box : the 'Next' button will be activated.

        Show
        Emmanuel Lecharny added a comment - There is a workaround : uncheck the "Get base DNs fro rootDSE" check box : the 'Next' button will be activated.
        Hide
        Przemyslaw Rudzki added a comment -

        BTW. on attachement 3 please look at what happens with LDAP Browser view on multiple double click of connection element from Connections view.

        Show
        Przemyslaw Rudzki added a comment - BTW. on attachement 3 please look at what happens with LDAP Browser view on multiple double click of connection element from Connections view.
        Hide
        Przemyslaw Rudzki added a comment -

        After migrating the data I can see the connection but still I cannot add a new one.

        Show
        Przemyslaw Rudzki added a comment - After migrating the data I can see the connection but still I cannot add a new one.
        Hide
        Przemyslaw Rudzki added a comment -

        I have freshly installed studio plugins twice for different version of Eclipse from http://directory.apache.org/studio/update/1.x.

        In addition I have downloaded standalone version and created a connection then I copied all .ApacheDirectoryStudio/.metadata/.plugins/org.apache.directory.studio* stuff to my current workspace and I can access the configured LDAP server.

        Still no possiblity to create a new connection.

        Show
        Przemyslaw Rudzki added a comment - I have freshly installed studio plugins twice for different version of Eclipse from http://directory.apache.org/studio/update/1.x . In addition I have downloaded standalone version and created a connection then I copied all .ApacheDirectoryStudio/.metadata/.plugins/org.apache.directory.studio* stuff to my current workspace and I can access the configured LDAP server. Still no possiblity to create a new connection.
        Hide
        Emmanuel Lecharny added a comment -

        May be you just updated from 1.0.0 ?

        In this case, there is a pb with already created connections, as the configuration file format has changed.

        Just try to remove the previous configuration file in :
        ~/ApacheDirectoryStudio/.metadata/.plugins/org.apache.directory.studio.ldapbrowser.core

        You will loose your previous connection configuration, but I thing you will be able to create new ones.

        Btw, this is a bug : we should be able to read previous configuration files in newer versions...

        Show
        Emmanuel Lecharny added a comment - May be you just updated from 1.0.0 ? In this case, there is a pb with already created connections, as the configuration file format has changed. Just try to remove the previous configuration file in : ~/ApacheDirectoryStudio/.metadata/.plugins/org.apache.directory.studio.ldapbrowser.core You will loose your previous connection configuration, but I thing you will be able to create new ones. Btw, this is a bug : we should be able to read previous configuration files in newer versions...
        Hide
        Przemyslaw Rudzki added a comment -

        The same happens for Eclipse 3.2.2

        Show
        Przemyslaw Rudzki added a comment - The same happens for Eclipse 3.2.2
        Hide
        Przemyslaw Rudzki added a comment - - edited

        See Attachement: this is what I mean.

        Show
        Przemyslaw Rudzki added a comment - - edited See Attachement: this is what I mean.

          People

          • Assignee:
            Pierre-Arnaud Marcelot
            Reporter:
            Przemyslaw Rudzki
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development