Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-184

Error while reading entry in Active Directory

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 0.8.0, 0.8.1
    • Fix Version/s: 1.1.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None
    • Environment:
      Windows XP SP2, Java 1.6.02
      Windows 2003 SP1 Active Directory

      Description

      Connected to an Windows 2003 Active Directory on port 389 as Administrator.
      When clicking the + on my domain the first time after connecting I get an error:

      Read Children
      Error while reading entry
      Unprocessed Continuation Reference(s)
      Unprocessed Continuation Reference(s)

      After clicking OK I can continue to work normally.
      This error doesn't occur when I connect to my eDirectory.

        Activity

        Pierre-Arnaud Marcelot made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Hide
        Pierre-Arnaud Marcelot added a comment -

        Version 1.1.0 has been released.
        Closing this issue.

        Show
        Pierre-Arnaud Marcelot added a comment - Version 1.1.0 has been released. Closing this issue.
        Stefan Seelmann made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Show
        Stefan Seelmann added a comment - Fixed here: http://svn.apache.org/viewcvs?view=rev&rev=594711
        Stefan Seelmann made changes -
        Component/s studio-ldapbrowser [ 12311538 ]
        Assignee Stefan Seelmann [ seelmann ]
        Fix Version/s 1.1.0 [ 12312701 ]
        Hide
        Emmanuel Lecharny added a comment -

        It should be related on the wy we treat referals in Studio. The client should be in charge of following referals when the server send a result containing one. Not complicated to fix anyway, it's just a question of sending a second request using the LdapURL received, until we get aither a reply or an error.

        There is just one tricky pb to handle carefully : referrals can be cyclic, so we should just avoid sending a requests to a server which has sent back a referral.

        Show
        Emmanuel Lecharny added a comment - It should be related on the wy we treat referals in Studio. The client should be in charge of following referals when the server send a result containing one. Not complicated to fix anyway, it's just a question of sending a second request using the LdapURL received, until we get aither a reply or an error. There is just one tricky pb to handle carefully : referrals can be cyclic, so we should just avoid sending a requests to a server which has sent back a referral.
        Hide
        Aleks M added a comment -

        This still occurs in 1.0.1

        Show
        Aleks M added a comment - This still occurs in 1.0.1
        Aleks M made changes -
        Field Original Value New Value
        Attachment screenshot-1.jpg [ 12365246 ]
        Hide
        Aleks M added a comment -

        Btw, I only get this error in LDAP Studio. Not in LDAP Browser 2.8.2 or MS AD Explorer.
        Thanks.

        Show
        Aleks M added a comment - Btw, I only get this error in LDAP Studio. Not in LDAP Browser 2.8.2 or MS AD Explorer. Thanks.
        Aleks M created issue -

          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Aleks M
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development