Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-152

New entry creator does not know that 'dc' and 'domainComponent' is the same thing

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.1.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None
    • Environment:
      Apache Directory Studio 0.8.0 stand-alone plugin with eclipse RCP 3.2.0 operating on OpenLDAP 2.3 server

      Description

      I want to create an entry with domain objectClass. The only MUST attribute required by this objectClass is the domainComponent or dc. The schema definition allows use of both these names, but the entry creator tries to be smarter. When I specify the DN as dc=subdomain,dc=example,dc=com in the third step of creating a new entry and go to the last step, the entry editor lists the dc attribute in normal font and makes me enter the domainComponent which is listed in bold font.
      So I end up with both dc and domainComponent attributes to make the "Finish" button active. Because the dc attribute is the part of the dn I cannot delete it, because the entry creator thinks that I still have to enter the domainComponent attribute I cannot delete it neither. When I finish creating the entry the server responds with a "Error while creating entry [LDAP: error code 20 - attribute 'dc' provided more than once] " error.

        Activity

        Stefan Seelmann added a comment -

        The same is true for other attributes with multiple names like [sn, surname] or [cn, commonName]. Seems like the wizard is really a bit to smart.

        Mateusz Kijowski added a comment -

        Also I didn't encounter such problems in 0.6. It seems odd that this kind of regression wasn't addresed before the 1.0 release.

        Emmanuel Lecharny added a comment -

        This is obviously because unit testing a GUI is not an easy task that this kind of regression wasn't detected before 0.8 !

        Any person having a good idea about how to write regression tests for this GUI is welcome !

        Stefan Seelmann added a comment -

        Fixed in trunk and studio-maven branch.

        I just added a short-term fix for now. I saw some more problems when using alternative names or OIDs of attributes and object classes. The reason is that sometimes we just compare the Strings of attribute descriptions. We have to fix these problems together with DIRSTUDIO-128, which is addressed for version 1.2.

        Pierre-Arnaud Marcelot added a comment -

        Version 1.1.0 has been released.
        Closing this issue.


          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Mateusz Kijowski
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development