Uploaded image for project: 'Directory Studio'
  1. Directory Studio
  2. DIRSTUDIO-1280

Studio browser connections to replicated LDAP dont work with Mac OS Big Sur



    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 2.0.0-M16
    • 2.0.0-M17
    • studio-ldapbrowser
    • None
    • Mac OS Big Sur 11.2.3
      Mac OS Big Sur 11.4


      I was using Apache Studio to connect to my LDAP which is setup in a replicated topology. Mostly the LDAP Browser to view and edit data. This was working fine. But recently my Mac went through the Big Sur update and since then the studio browser to a replicated topology is not working.

      I see the Root DSE as blank on the LDAP Browser

      Reason I think this could be a Studio issue with the Mac Big Sur version

      1. I have investigated everything possible from my LDAP end and there have been no recent changes to begin with
      2. I ended up trying Apache Studio from my Windows laptop and that worked fine for the same LDAP. No issues with connection or browsing. That was with M13 version
      3. I have since tried JXplorer to isolate if maybe its something to do with MAC to LDAP connection rather than Studio to LDAP. But connections via JXplorer work fine - view as well as edits
      4. Re-importing connections to Studio did not work - I thought maybe the connections have a new format and the old one doesnt work anymore
      5. I tried it on a friend's laptop which is also MAC but older OS and it works fine there
      6. Trying to run an older version M14 in the Mac Big Sur results inĀ  - java.lang.NullPointerException: Cannot invoke "org.eclipse.swt.internal.cocoa.NSGraphicsContext.graphicsPort()" because "graphicsContext" is null




            Unassigned Unassigned
            si7 Sourabh Idoorkar
            0 Vote for this issue
            2 Start watching this issue