Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-115

Unable to edit operational attribute values

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.4.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None

      Description

      In some cases I find myself wanting to edit the value of an operational attribute, but find myself having to go to a different LDAP editor application to do it (or writing an LDIF). I guess Studio is doing this as it is assuming that operational attribute values are not editable, but in this case it is.

        Issue Links

          Activity

          Hide
          Martin Alderson added a comment -

          This is not a problem for all operational attributes (most likely dependent on the user modification flag in the attribute type).

          The attribute in question is one I just added to the schema and as far as I know it is not actually operational. I cannot add a value of that type to an extensibleObject entry.

          The attributeType is definately in the schema (I can see it in the cn=schema entry and I can add a value of that type to an entry using another LDAP editor app) .

          I think this bug is more to do with LDAP Studio not reading in the schema for some reason. I have also tried reconnecting by the way.

          Show
          Martin Alderson added a comment - This is not a problem for all operational attributes (most likely dependent on the user modification flag in the attribute type). The attribute in question is one I just added to the schema and as far as I know it is not actually operational. I cannot add a value of that type to an extensibleObject entry. The attributeType is definately in the schema (I can see it in the cn=schema entry and I can add a value of that type to an entry using another LDAP editor app) . I think this bug is more to do with LDAP Studio not reading in the schema for some reason. I have also tried reconnecting by the way.
          Hide
          Martin Alderson added a comment -

          Reloading the schema in the connection properties fixed this. I think this may have been a problem as the connection was created with an older version of studio. When I create a new connection the problem does not occur (the schema is reloaded automatically).

          Show
          Martin Alderson added a comment - Reloading the schema in the connection properties fixed this. I think this may have been a problem as the connection was created with an older version of studio. When I create a new connection the problem does not occur (the schema is reloaded automatically).
          Hide
          Stefan Seelmann added a comment -

          Operational attributes are now editable.

          Show
          Stefan Seelmann added a comment - Operational attributes are now editable.
          Hide
          Pierre-Arnaud Marcelot added a comment -

          Apache Directory Studio version 1.4.0 has been released.

          Show
          Pierre-Arnaud Marcelot added a comment - Apache Directory Studio version 1.4.0 has been released.

            People

            • Assignee:
              Stefan Seelmann
              Reporter:
              Martin Alderson
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development