Uploaded image for project: 'Directory Studio'
  1. Directory Studio
  2. DIRSTUDIO-1116

Attribute not sorted alphabetically for multiple entries

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Duplicate
    • Affects Version/s: 2.0.0-M10 (2.0.0.v20151221-M10)
    • Fix Version/s: 2.0.0-M11, 2.0.0-M12
    • Component/s: OpenLDAP Config
    • Labels:
      None

      Description

      I receive a new laptop and I have upgrade to the latest version.
      On my previous laptop all was working fine (Version 2.0.0.v20130628)

      I have some group with memberUid with a higher number of 10.
      When I extend the view, in my old configuration, all the user are sorted with alphabetic order.

      If I browse the same ldap tree on my new pc, they are all mixed.
      I try all sort of sorting but each time i got the same result, unable to have a good sorting. It seems that the ordering only sort the main value and not if they are within the same group (memberuid).

      Please check the screenshot on attach.

      Thanks in advance.

      steve Balon

        Issue Links

          Activity

          Hide
          elecharny Emmanuel Lecharny added a comment -

          Is this using the same Java version ?

          Show
          elecharny Emmanuel Lecharny added a comment - Is this using the same Java version ?
          Hide
          balon.steve@gmail.com steve balon added a comment -

          Hi,

          Not sure I need to check.
          My new laptop is using the latest version of Java : (build 1.8.0_101-b13)

          It should work with the latest version of java and latest directory studio.

          I will start my old laptop and check.

          steve

          Show
          balon.steve@gmail.com steve balon added a comment - Hi, Not sure I need to check. My new laptop is using the latest version of Java : (build 1.8.0_101-b13) It should work with the latest version of java and latest directory studio. I will start my old laptop and check. steve
          Hide
          balon.steve@gmail.com steve balon added a comment -

          Hi,

          I have also the same version of java installed on my old laptop.
          But also some old one.

          and it seems that apache directory studio is using a older one.

          C:\Program Files (x86)\Java\jre7-60\bin\client\jvm.dll
          eclipse.home.location=file:/C:/Program Files (x86)/Apache Directory Studio/
          eclipse.launcher=C:\Program Files (x86)\Apache Directory Studio\Apache Directory Studio.exe
          eclipse.launcher.name=Apache Directory Studio
          eclipse.product=org.apache.directory.studio.rcp.product
          eclipse.startTime=1473681824490
          eclipse.vm=C:\Program Files (x86)\Java\jre7-60\bin\client\jvm.dll
          eclipse.vmargs=-Djava.class.path=C:\Program Files (x86)\Apache Directory Studio\plugins\org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar

          where on my new device the log show :
          java.endorsed.dirs=C:\Program Files\Java\jre1.8.0_101\lib\endorsed
          java.ext.dirs=C:\Program Files\Java\jre1.8.0_101\lib\ext;C:\Windows\Sun\Java\lib\ext
          java.home=C:\Program Files\Java\jre1.8.0_101
          java.io.tmpdir=C:\Users\balon.s\AppData\Local\Temp\
          java.library.path=C:\Program Files\ApacheDirectoryStudio;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:/Program Files/Java/jre1.8.0_101/bin/server;C:/Program Files/Java/jre1.8.0_101/bin;C:/Program Files/Java/jre1.8.0_101/lib/amd64;

          steve

          Show
          balon.steve@gmail.com steve balon added a comment - Hi, I have also the same version of java installed on my old laptop. But also some old one. and it seems that apache directory studio is using a older one. C:\Program Files (x86)\Java\jre7-60\bin\client\jvm.dll eclipse.home.location= file:/C:/Program Files (x86)/Apache Directory Studio/ eclipse.launcher=C:\Program Files (x86)\Apache Directory Studio\Apache Directory Studio.exe eclipse.launcher.name=Apache Directory Studio eclipse.product=org.apache.directory.studio.rcp.product eclipse.startTime=1473681824490 eclipse.vm=C:\Program Files (x86)\Java\jre7-60\bin\client\jvm.dll eclipse.vmargs=-Djava.class.path=C:\Program Files (x86)\Apache Directory Studio\plugins\org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar where on my new device the log show : java.endorsed.dirs=C:\Program Files\Java\jre1.8.0_101\lib\endorsed java.ext.dirs=C:\Program Files\Java\jre1.8.0_101\lib\ext;C:\Windows\Sun\Java\lib\ext java.home=C:\Program Files\Java\jre1.8.0_101 java.io.tmpdir=C:\Users\balon.s\AppData\Local\Temp\ java.library.path=C:\Program Files\ApacheDirectoryStudio;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:/Program Files/Java/jre1.8.0_101/bin/server;C:/Program Files/Java/jre1.8.0_101/bin;C:/Program Files/Java/jre1.8.0_101/lib/amd64; steve
          Hide
          seelmann Stefan Seelmann added a comment -

          This is a know problem in M10 and solved in trunk and will be available in next release, see DIRSTUDIO-1090. In the meantime you may want to try the latest snapshot build from https://builds.apache.org/view/A-D/view/Directory/job/dir-studio/

          Show
          seelmann Stefan Seelmann added a comment - This is a know problem in M10 and solved in trunk and will be available in next release, see DIRSTUDIO-1090 . In the meantime you may want to try the latest snapshot build from https://builds.apache.org/view/A-D/view/Directory/job/dir-studio/

            People

            • Assignee:
              Unassigned
              Reporter:
              balon.steve@gmail.com steve balon
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development