Uploaded image for project: 'Directory Studio'
  1. Directory Studio
  2. DIRSTUDIO-1098

Refresh of entry causes: "Unhandled event loop exception"

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-M10 (2.0.0.v20151221-M10)
    • Fix Version/s: 2.0.0-M12
    • Component/s: studio-ldifeditor
    • Labels:
      None

      Description

      Context:

      When I try to refresh(F5 or via Refresh Button/Context Menu entry) a entry with a custom schema or with posixAccount schema( not tried other schemes yet) editor and the entry has no changes, it causes a Exception. If the entry got changed the exception is not thrown.

      Kind Regards

      David

      Detailed Informations:
      eclipse.buildId=unknown
      java.version=1.8.0_74
      java.vendor=Oracle Corporation
      BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=de_DE
      Framework arguments: /studio-rcp/resources/icons/linux/studio.xpm -keyring /Users/David/.eclipse_keyring -showlocation
      Command-line arguments: -os macosx -ws cocoa -arch x86_64 /studio-rcp/resources/icons/linux/studio.xpm -keyring /Users/David/.eclipse_keyring -showlocation

      org.eclipse.ui
      Fehler
      Mon Mar 07 16:20:05 CET 2016
      Unhandled event loop exception

      org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)
      at org.eclipse.swt.SWT.error(SWT.java:4441)
      at org.eclipse.swt.SWT.error(SWT.java:4356)
      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:139)
      at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3994)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3671)
      at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1151)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
      at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1032)
      at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:148)
      at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:636)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:579)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
      at org.apache.directory.studio.Application.start(Application.java:51)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:498)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
      Caused by: java.lang.NullPointerException
      at org.apache.directory.studio.entryeditors.EntryEditorManager$3.entryUpdated(EntryEditorManager.java:361)
      at org.apache.directory.studio.ldapbrowser.core.events.EventRegistry$4$1.run(EventRegistry.java:237)
      at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:136)
      ... 23 more

        Activity

        elecharny Emmanuel Lecharny added a comment -

        I have fixed the NPE, but I'm not sure there isn't more to do :

        http://svn.apache.org/viewvc?rev=1734037&view=rev

        seelmann Stefan Seelmann added a comment -

          People

          • Assignee:
            Unassigned
            Reporter:
            david.kaatz David Kaatz
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development