Uploaded image for project: 'Directory Studio'
  1. Directory Studio
  2. DIRSTUDIO-1045

New Connection problem - ERR_04269 ATTRIBUTE_TYPE for OID ads-basedn does not exist

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Not A Problem
    • Affects Version/s: 2.0.0-M8 (2.0.0.v20130628)
    • Component/s: studio-connection
    • Labels:
      None
    • Environment:
      Windows 7, 64 bit

      Description

      Setup a new, first Connection. Then try to "Open Configuration" - doesn't work - error message in the summary and here the detailed error message:

      org.apache.directory.api.ldap.model.exception.LdapNoSuchAttributeException: ERR_04269 ATTRIBUTE_TYPE for OID ads-basedn does not exist!
      at org.apache.directory.api.ldap.model.schema.registries.DefaultAttributeTypeRegistry.lookup(DefaultAttributeTypeRegistry.java:293)
      at org.apache.directory.api.ldap.model.schema.registries.DefaultAttributeTypeRegistry.lookup(DefaultAttributeTypeRegistry.java:47)
      at org.apache.directory.api.ldap.schemamanager.impl.DefaultSchemaManager.lookupAttributeTypeRegistry(DefaultSchemaManager.java:1604)
      at org.apache.directory.api.ldap.model.entry.DefaultEntry.<init>(DefaultEntry.java:311)
      at org.apache.directory.studio.apacheds.configuration.v2.jobs.LoadConfigurationRunnable.readConfiguration(LoadConfigurationRunnable.java:359)
      at org.apache.directory.studio.apacheds.configuration.v2.jobs.LoadConfigurationRunnable.getConfiguration(LoadConfigurationRunnable.java:182)
      at org.apache.directory.studio.apacheds.configuration.v2.jobs.LoadConfigurationRunnable.run(LoadConfigurationRunnable.java:127)
      at org.apache.directory.studio.common.core.jobs.StudioJob.run(StudioJob.java:83)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
      Caused by: org.apache.directory.api.ldap.model.exception.LdapException: ERR_04269 ATTRIBUTE_TYPE for OID ads-basedn does not exist!
      at org.apache.directory.api.ldap.model.schema.registries.DefaultSchemaObjectRegistry.lookup(DefaultSchemaObjectRegistry.java:176)
      at org.apache.directory.api.ldap.model.schema.registries.DefaultAttributeTypeRegistry.lookup(DefaultAttributeTypeRegistry.java:289)
      ... 8 more

        Activity

        elecharny Emmanuel Lecharny added a comment -

        The current LDAP Studio version does not work with the latest ApacheDS 2.0.0-M20 revision. We are working on releasing Studio with support for the changed attributes.

        nussbaum Andra added a comment -

        yeah, I've noticed it myself in the end - after trying with older client version (that have other problems, etc.), and after also eclipse luna doesn t really work with the M-7 client => I've tried with older server versions, and yes, it works with the ApacheDS 2.0.0-M19.

        thanks for your promt reply anyway,
        A.

        olimination oliver.burkhalter added a comment -

        Hi Emmanuel Lecharny,

        is there any quick workaround for the time being? I guess editing the config files directly in the filesystem is the only way...

        thanks for feedback

        seelmann Stefan Seelmann added a comment -

        Yes, the only way is to manually edit the config files. I'll close the issue.

        seelmann Stefan Seelmann added a comment -

        Studio 2.0.0-M8 doesn't support ApacheDS 2.0.0-M20 configuration. Support is added to next Studio 2.0.0-M9 release.


          People

          • Assignee:
            Unassigned
            Reporter:
            nussbaum Andra
          • Votes:
            3 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development