Directory ApacheDS
  1. Directory ApacheDS
  2. DIRSERVER-4

Actions should be externalized in the gramars

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: asn1
    • Labels:
      None

      Description

      Actions are described as functors in the grammar's transitions. They should be named and declared outside.

        Activity

        Emmanuel Lecharny created issue -
        Alex Karasulu made changes -
        Field Original Value New Value
        Project Directory ASN1 [ 10517 ] ApacheDS [ 12310260 ]
        Component/s asn1 [ 12310712 ]
        Key DIRSNICKERS-119 DIRSERVER-4
        Type Improvement [ 4 ] Bug [ 1 ]
        Emmanuel Lecharny added a comment -

        This is not a bug, but an improvment

        Emmanuel Lecharny made changes -
        Type Bug [ 1 ] Improvement [ 4 ]
        Emmanuel Lecharny added a comment -

        Not necessarily a good idea. Having actions among grammar transition helps a lot if one want to understand what is going on.

        Emmanuel Lecharny made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Emmanuel Lecharny added a comment -

        rejected

        Emmanuel Lecharny made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        230d 9h 32m 1 Emmanuel Lecharny 26/Aug/06 12:03
        Resolved Resolved Closed Closed
        12s 1 Emmanuel Lecharny 26/Aug/06 12:03

          People

          • Assignee:
            Emmanuel Lecharny
            Reporter:
            Emmanuel Lecharny
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development