Uploaded image for project: 'Directory ApacheDS'
  1. Directory ApacheDS
  2. DIRSERVER-2199

No users returned if application requests sorting

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Cannot Reproduce
    • 2.0.0-M23
    • None
    • ldap
    • None
    • Windows 2012 server

    Description

      We are using Apache DS with our BI application (IBM Cognos ver 11.6) and have discovered that when attempting to browse the our namespace (our 'ou') nothing is being returned.
      IBM development team have indicated the issue is on the Apache side and have suggested that the request from the IBM Cognos application returns sorted values, and as a result, no users (or goups) are returned.
      We are able to search for individual users or groups, but a sorted list of all users or groups in the 'ou' is not being displayed.
      We believe this is similar to the issue recorded in ver .20, but noticed it has been resolved in build .23.
      We have an environment set up with a working testcase if you would like to walk through the issue.

      thanks
      Jeremy

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              jackson.jeremy Jeremy Jackson
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: