Uploaded image for project: 'Directory ApacheDS'
  1. Directory ApacheDS
  2. DIRSERVER-2116

ApacheDS failed to start after every reboot and throwing error ERR_250_ENTRY_ALREADY_EXISTS dc=example,dc=com already exists!



    • Bug
    • Status: Open
    • Major
    • Resolution: Unresolved
    • 2.0.0-M21
    • None
    • jdbm
    • None
    • Ubuntu 14.04.3 LTS trusty


      I downloaded ApcheDS Debian Package (apacheds-2.0.0-M21-amd64.deb )
      and installed on Ubuntu server for my personal testing of LDAP .
      It worked very well after i installed and configured on my server .
      But problems arise when my server rebooted every-time .
      After every reboot i have to start the ApacheDS server manually by follwing command
      *sudo /etc/init.d/apacheds-2.0.0-M21-default start
      And immediately i got following reply
      Starting ApacheDS - default...
      ApacheDS - default is already running. *

      But this is not true. i observed there is no process running which are associated with ApacheDS in OS
      After referring the one of the solution given in this list i just clear the pid file contents ( /var/lib/apacheds-2.0.0-M21/default/run/apacheds-default.pid) and overcome the first problem .

      But still it failed to start and i observed below errors in log file

      {{jvm 1 | [15:51:29] ERROR [org.apache.directory.server.wrapper.ApacheDsTanukiWrapper] - Failed to start the service.
      jvm 1 | org.apache.directory.api.ldap.model.exception.LdapOtherException: ERR_250_ENTRY_ALREADY_EXISTS dc=example,dc=com already exists!
      jvm 1 | at org.apache.directory.server.core.api.partition.AbstractPartition.initialize(AbstractPartition.java:94)
      jvm 1 | at org.apache.directory.server.core.DefaultDirectoryService.initialize(DefaultDirectoryService.java:1813)
      jvm 1 | at org.apache.directory.server.core.DefaultDirectoryService.startup(DefaultDirectoryService.java:1250)
      jvm 1 | at org.apache.directory.server.ApacheDsService.initDirectoryService(ApacheDsService.java:318)
      jvm 1 | at org.apache.directory.server.ApacheDsService.start(ApacheDsService.java:182)
      jvm 1 | at org.apache.directory.server.wrapper.ApacheDsTanukiWrapper.start(ApacheDsTanukiWrapper.java:72)
      jvm 1 | at org.tanukisoftware.wrapper.WrapperManager$12.run(WrapperManager.java:2788) }}

      i would like to know that should i reinstall the ApacheDS evertyime when server reboot ?

      i tried several solutions mentioned in web to overcome this none worked for me except reinstall




            Unassigned Unassigned
            aadi AADI
            1 Vote for this issue
            6 Start watching this issue