Details

    • Type: Test
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0.0-M20
    • Component/s: None
    • Labels:
      None

      Description

      ClientInitialRefreshIT fails consistently for me on my local machine. There are two problems with it:

      a) The tests that subsequently add a new entry don't have the deletion code in a "finally" block. So if one test fails, another 2 end up failing
      b) The root cause is the testInitialRefreshStopAndGo, where replication may not be finished by the time the consumer is stopped. A small (0.5s) sleep does the job here.

      1. dirserver-2037.patch
        2 kB
        Colm O hEigeartaigh

        Activity

        coheigea Colm O hEigeartaigh added a comment -

        A patch for this issue.

        Colm.


          People

          • Assignee:
            Unassigned
            Reporter:
            coheigea Colm O hEigeartaigh
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development