Directory ApacheDS
  1. Directory ApacheDS
  2. DIRSERVER-1744

Compex LDAP search filters returning unmatched objects

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-M6
    • Fix Version/s: 2.0.0-M8
    • Component/s: ldap
    • Labels:
      None
    • Environment:
      CentOS 5.6

      Description

      I used ApacheDirectoryStudio-linux-x86_64-2.0.0.v20120224 and created an Apache DS server with it. The root DSE reported version of this server is 2.0.0-M6.

      The same problem is also present in the Apache DS bundled with ApacheDirectoryStudio-linux-x86_64-1.5.3.v20100330

      I created the dc=example,dc=com context and the following group

      dn: cn=g1,dc=example,dc=com
      objectClass: groupOfNames
      objectClass: top
      member: dc=example,dc=com
      cn: g1

      I Searched with

      ldapsearch -x -h localhost -p 10389 -D uid=admin,ou=system -w secret -b dc=example,dc=com '(&(objectclass=groupofnames)(owner=*))'

      nothing is returned which is correct

      ldapsearch -x -h localhost -p 10389 -D uid=admin,ou=system -w secret -b dc=example,dc=com '(&(|(objectclass=groupofnames))(owner=*))'

      nothing is returned as expected

      ldapsearch -x -h localhost -p 10389 -D uid=admin,ou=system -w secret -b dc=example,dc=com '(&(|(&(objectclass=groupofnames)))(owner=*))'

      the group g1 is returned which is not expected, and other directories do not return objects with this same setup. The actual filters I want to use are more complicated than this, but this is the simplest one that demonstrates the issue.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        46d 21h 19m 1 Emmanuel Lecharny 02/Oct/12 21:12
        Resolved Resolved Closed Closed
        226d 15h 39m 1 Emmanuel Lecharny 17/May/13 12:51
        Emmanuel Lecharny made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Emmanuel Lecharny added a comment -

        Closed all the resolved issues

        Emmanuel Lecharny made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 2.0.0-M8 [ 12320058 ]
        Resolution Fixed [ 1 ]
        Emmanuel Lecharny added a comment -

        This was a bug deep i the Request decoder. The filters were not built correctly on the server.
        Fixed with http://svn.apache.org/viewvc?rev=1393069&view=rev
        Test added in http://svn.apache.org/viewvc?rev=1393068&view=rev

        Emmanuel Lecharny added a comment -

        My bad, it does not work well in trunk :/

        I'm going to check what's going on...

        Richard Hardy added a comment -

        I just tried M7, the behavior is the same. I do not have an urgent need for this to be fixed, so it is good news that the problem is not in the trunk code.
        Thanks.

        Emmanuel Lecharny added a comment -

        And for your information, the third filter returns nothing on trunk (haven't tested it on 2.0.0-M7) so it seems that the pb has been fixed since M6...

        Emmanuel Lecharny added a comment -

        Btw, I confirm that 2.0.0-M6 dpes not work well with the third filter.

        Emmanuel Lecharny added a comment -

        Have you tried with the latest version, 2.0.0-M7 ?

        Richard Hardy created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Richard Hardy
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development