Directory ApacheDS
  1. Directory ApacheDS
  2. DIRSERVER-1705

Alphanumeric attribute accepts non alpha characters but throws exception in equality match rule,

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0.0-M6
    • Fix Version/s: None
    • Component/s: core
    • Labels:
      None
    • Environment:
      Win32, Java 1.6.0_31

      Description

      In RFC 2798 sec 2.4, the employeeNumber is defined as:

      "Numeric or alphanumeric identifier assigned to a person, typically based on order of hire or association with an organization. Single valued."

      Adding the value 'john.smith' to the field employeeNumber is allowed but when searching for it like this:
      employeeNumber=john.smith

      The exception below is thrown.

      Error while performing search

      • [LDAP: error code 80 - OTHER: failed for MessageType : SEARCH_REQUES
        javax.naming.NamingException: [LDAP: error code 80 - OTHER: failed for MessageType : SEARCH_REQUEST
        Message ID : 7
        SearchRequest
        baseDn : 'ou=int,o=acme'
        filter : '(employeeNumber=john.smith:[9223372036854775807])'
        scope : whole subtree
        typesOnly : false
        Size Limit : 1000
        Time Limit : no limit
        Deref Aliases : deref In Searching
        attributes : 'displayName', 'objectClass'
        org.apache.directory.shared.ldap.model.message.SearchRequestImpl@249c7220: null]; remaining name 'ou=int,o=acme'
        at com.sun.jndi.ldap.LdapCtx.mapErrorCode(Unknown Source)
        at com.sun.jndi.ldap.LdapCtx.processReturnCode(Unknown Source)
        at com.sun.jndi.ldap.LdapCtx.processReturnCode(Unknown Source)
        at com.sun.jndi.ldap.LdapNamingEnumeration.getNextBatch(Unknown Source)
        at com.sun.jndi.ldap.LdapNamingEnumeration.hasMoreImpl(Unknown Source)
        at com.sun.jndi.ldap.LdapNamingEnumeration.hasMore(Unknown Source)
        at org.apache.directory.studio.connection.core.io.jndi.StudioNamingEnumeration.hasMore(StudioNamingEnumeration.java:139)
        at org.apache.directory.studio.ldapbrowser.core.jobs.SearchRunnable.searchAndUpdateModel(SearchRunnable.java:323)
        at org.apache.directory.studio.ldapbrowser.core.jobs.SearchRunnable.run(SearchRunnable.java:184)
        at org.apache.directory.studio.connection.core.jobs.StudioConnectionJob.run(StudioConnectionJob.java:114)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

        Activity

        Emmanuel Lecharny added a comment -

        It seems to be fixed in trunk. I tried to add an entry with EmployeeNumber=john.smith, and to search it with (EmployeeNumber=john.smith), and got back teh entry with no error.


          People

          • Assignee:
            Unassigned
            Reporter:
            Carlo Accorsi
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development