Uploaded image for project: 'Directory ApacheDS'
  1. Directory ApacheDS
  2. DIRSERVER-1586

2.0 does not have a way to load external Ldifs (h.350)

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 2.0.0
    • Fix Version/s: 2.1.0
    • Component/s: core
    • Labels:
      None
    • Environment:
      Running on windows XP and Windows 2003 server

      Description

      We need a method that is consistent with ldif files exported from Apache directory Studio, that can be loaded to extend the schema of our server.

      In 1.5.3 I did ApacheDS.setLdifDirectory, then when the LDAP server started, it imported and used the ldif definitions in that directory. I have exhausted all methods I could find to load these LDIF files.

      I tried ApplyLdifs, but that takes a description parameter that is part of Junit, not real good for production code, and the Description I can get out of Junit does not have the getAnnotation method on it.

      I tried DSAnnotationProcessor.injectLdifFiles directly, but it could never open the file names i gave it.

      I tried writing my own injectLdifFiles method, but always got an error when trying to add attributes to an objectclass that I had just added, saying that this objectClass is not yet loaded.

      I tried making my own implementation of AbstractSchemaLoader, but that pukes saying that all schemas must have a valid creatorsName attribute.

        Attachments

        1. commObject.ldif
          3 kB
          Steve hammond
        2. XmppURIObject.ldif
          3 kB
          Steve hammond

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              webshammo Steve hammond
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: