Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Invalid
    • Affects Version/s: 1.5.5
    • Fix Version/s: None
    • Component/s: core
    • Labels:
      None
    • Environment:
      Linux, java version "1.6.0_21"

      Description

      I am getting NPE during apache ds startup.

      Stacktrace.
      Exception in thread "main" java.lang.NullPointerException
      at org.apache.directory.server.core.authz.DefaultAuthorizationInterceptor.loadAdministrators(DefaultAuthorizationInterceptor.java:164)
      at org.apache.directory.server.core.authz.DefaultAuthorizationInterceptor.init(DefaultAuthorizationInterceptor.java:142)
      at org.apache.directory.server.core.interceptor.InterceptorChain.register0(InterceptorChain.java:441)
      at org.apache.directory.server.core.interceptor.InterceptorChain.register(InterceptorChain.java:397)
      at org.apache.directory.server.core.interceptor.InterceptorChain.init(InterceptorChain.java:257)
      at org.apache.directory.server.core.DefaultDirectoryService.initialize(DefaultDirectoryService.java:1617)
      at org.apache.directory.server.core.DefaultDirectoryService.startup(DefaultDirectoryService.java:971)
      at org.apache.directory.server.configuration.ApacheDS.startup(ApacheDS.java:115)
      at org.apache.directory.server.Service.initLdap(Service.java:136)
      at org.apache.directory.server.Service.init(Service.java:78)
      at org.apache.directory.server.UberjarMain.main(UberjarMain.java:55)

        Activity

        Emmanuel Lecharny added a comment -

        Try with 1.5.7.

        1.5.5 is totally outdated.

        mayank maria added a comment -

        It is not possible to change to 1.5.7 easily...
        Can you please elaborate whats the issue.. with this version ?

        mayank maria added a comment -

        The complete stack trace is as follows
        $ ./apacheds.sh
        _ _ ____ ____
        / \ _ __ ___ __| |_ ___| _ \/ ___|
        / _ \ | '_ \ / ` |/ __| ' \ / _ \ | | ___ \
        / ___ | |) | (| | (_| | | | __/ || |___) |
        // _\ ./ _,|_|| ||_|__/|___/

        _

        [04:59:35] WARN [org.apache.directory.server.schema.registries.DefaultOidRegistry] - OID for name 'krb5PrincipalName' was not found within the OID registry
        [04:59:35] ERROR [org.apache.directory.server.schema.registries.DefaultAttributeTypeRegistry] - attributeType w/ OID 2.5.4.16 not registered!
        Exception in thread "main" java.lang.NullPointerException
        at org.apache.directory.server.core.authz.DefaultAuthorizationInterceptor.loadAdministrators(DefaultAuthorizationInterceptor.java:164)
        at org.apache.directory.server.core.authz.DefaultAuthorizationInterceptor.init(DefaultAuthorizationInterceptor.java:142)
        at org.apache.directory.server.core.interceptor.InterceptorChain.register0(InterceptorChain.java:441)
        at org.apache.directory.server.core.interceptor.InterceptorChain.register(InterceptorChain.java:397)
        at org.apache.directory.server.core.interceptor.InterceptorChain.init(InterceptorChain.java:257)
        at org.apache.directory.server.core.DefaultDirectoryService.initialize(DefaultDirectoryService.java:1617)
        at org.apache.directory.server.core.DefaultDirectoryService.startup(DefaultDirectoryService.java:971)
        at org.apache.directory.server.configuration.ApacheDS.startup(ApacheDS.java:115)
        at org.apache.directory.server.Service.initLdap(Service.java:136)
        at org.apache.directory.server.Service.init(Service.java:78)
        at org.apache.directory.server.UberjarMain.main(UberjarMain.java:55

        apacheds_1.5.5]$

        Emmanuel Lecharny added a comment -

        We don't fix old ersions. If you can't switch to a more recent version, then pacth 1.5.5 yourself !

        here are very valid reason why we release new versions : like there are deadly bugs in older ones.

        mayank maria added a comment -

        I do know there will be many reasons for new release. But, at least expected some information from the org.
        Its disappointing.

        Emmanuel Lecharny added a comment -

        It's disappointing only from your POV. Again, there are valid reasons why we do release new versions, including fixing bugs. We are all volunteers, and we don't have time to look at old versions problem, so when we tell you : switch to a new version, it's because then we will be able to provide help.

        Just wondering what M$ tells you when you contact them because you have an issue in Windows 98 ???

        mayank maria added a comment -

        I think i understand "Product life cycle" much better as working for a product based company.

        Its not only disappointing from my "POV", but also its disappointing that nobody even tried to know the issue.
        Bluntly, its mentioned to switch to new version. Is it the kind of service to be expected ?
        "FYI - Anyhow the issue has been resolved."

        Product version's keep on coming as it is "the product life cycle". What if the next product is released next day... Will everybody post the answer "Try with 1.5.9. 1.5.7 is totally outdated."

        Volunteering don't means to just throw away on issues which are not related to present product. It would have been good/better if some pointers to the issue would have been given even if they will not resolve the issue.

        Let me know if it works only against M$. Then probably would have got much better service and could have provided the amt too.

        Emmanuel Lecharny added a comment -

        We don't provide service. We provide help, for free.

        In this very case, the help we provide is to tell you to switch to a more recent version, to check if the problem still occurs, and then to fill a JIRA with a compete description of your problem, configuration used, and eventually everything necessary to reproduce the problem. If so, we will be pleased to provide a patch, but unless you do that, our limited time does not let us spend some energy on a more than one year release version, with a problem very likely to have been solved since then (since we released 1.5.5, we have injected more than 5000 code modifications).

        If you feel like getting some real service, get ready to pay load of money for it. As we don't accept money here, we just provide a 'best effort', and again, it's 'go upgrade and come back'.

        You can also debug the code, provide the patch, and eventually see it being injected in a branch.

        Participate, stop whining !


          People

          • Assignee:
            Unassigned
            Reporter:
            mayank maria
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1h
              1h
              Remaining:
              Remaining Estimate - 1h
              1h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development