Directory ApacheDS
  1. Directory ApacheDS
  2. DIRSERVER-1521

dc=example,dc=com DIT no longer exists as a default partition (DIT) in 1.5.7?

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.5.7
    • Fix Version/s: 2.0.0-M13
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows

      Description

      I've done a "by default" installation of AD Server 1.5.7 in Widnows (as well as AD Studio 1.5.3).

      I've followed step-by-step what's written in http://directory.apache.org/apacheds/1.5/142-changing-the-admin-password.html (even though I don't need to change admin password).

      However, I can't see the dc=example,dc=com partition as shown in the 3rd figure. This could be very annoying for new users.

      The following section (http://directory.apache.org/apacheds/1.5/143-adding-your-own-partition-resp-suffix.html) also talks about this DIT which isn't there anymore.

      The on-line doc should be changed or dc=example,dc=com partition should be added back to the default installation.

      1. BROWSER1.png
        92 kB
        David Tonhofer
      2. BROWSER2.png
        105 kB
        David Tonhofer

        Activity

        TFS created issue -
        Emmanuel Lecharny added a comment -

        We will fix that in 2.0-RC2.

        The reason why the dc=example,dc=com does not exist is that its context entry does not exist by default. It has to be added.

        We will probably put it back in the default installation, because it's really a pain in the name a part of your body you sit on usually for new commers.

        Emmanuel Lecharny made changes -
        Field Original Value New Value
        Fix Version/s 2.0.0-RC2 [ 12315095 ]
        TFS added a comment -

        Or you could ask if the user would like to have dc=example,dc=com during setup (by default, yes) so advanced users don't need to have it. If this doesn't cause too much trouble in programming the setup.

        Emmanuel Lecharny added a comment -

        The problem is that creating an entry from scratch is not an easy thing : you have to check the the ObjectClasses are correct, that all the MUST attributeType are present, that the RDN is present too, plus many other corner cases.

        The best would probably be not to add the ou=example partition at all and to work on a better documentation (IMHO) ...

        TFS added a comment -

        But you don't have to create the entry from scratch, and that's not what I was asking for.

        The <jdbmPartition id="example" ...> element is already there inside server.xml file and I suppose its structure is valid. So there's really nothing to do.

        All you have to do is to add the context entry (even though I don't really understand what it is) when the users want it during setup.

        David Tonhofer added a comment -

        One could simply document this appropriately. I fired up the Apache Directory Studio, then fumbled around I found the "New Context Entry" item on the dropdown menu on the "Root DSE", then fumbled some more to get entries visible in the tree (they already were visible in the "Root DSE" pane).

        ...but what is the little number behind the "Root DSE" icon? The id of the next context that will be created??

        David Tonhofer added a comment -

        Some screenshots

        David Tonhofer made changes -
        Attachment BROWSER1.png [ 12448327 ]
        Attachment BROWSER2.png [ 12448328 ]
        Emmanuel Lecharny added a comment -

        The number behind the rootDSE entry is the number of leaves you have in the tree (here, 5 = 4 + the RootDSE itself).

        About the context entry, as I said, it's really a LDAP entry, when what you see in the browaser is just the namingContext stored in the RootDSE (which is just a DN, not an entry).

        It's all documented here http://directory.apache.org/apacheds/1.5/143-adding-your-own-partition-resp-suffix.html, except the right click on the rootDSE, which is explain in http://directory.apache.org/studio/static/users_guide/ldap_browser/tools_newcontextentry_wizard.html

        Emmanuel Lecharny added a comment -

        We now recreate the entry by default, or we use the one provided in the config

        Emmanuel Lecharny made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 2.0.0-RC1 [ 12313387 ]
        Fix Version/s 2.0.0-RC2 [ 12315095 ]
        Resolution Fixed [ 1 ]
        Emmanuel Lecharny made changes -
        Fix Version/s 2.0.0-M13 [ 12324631 ]
        Fix Version/s 2.0.0-RC1 [ 12313387 ]
        Emmanuel Lecharny made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1054d 7h 18m 1 Emmanuel Lecharny 07/May/13 22:41
        Resolved Resolved Closed Closed
        43d 12h 31m 1 Emmanuel Lecharny 20/Jun/13 11:12

          People

          • Assignee:
            Unassigned
            Reporter:
            TFS
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development