Directory ApacheDS
  1. Directory ApacheDS
  2. DIRSERVER-1447

loadAllEnabled() method is taking way too long

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-RC1
    • Fix Version/s: 2.0.0-M13
    • Component/s: None
    • Labels:
      None

      Description

      Loading the schema into the registries with the loadAllEnabled() method takes more than 7 seconds on my laptop. The problem is that for each schema, and for each type of schemaObject, the disk is parsed looking for some pattern. We should improve that.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1242d 19h 13m 1 Emmanuel Lecharny 18/May/13 05:24
        Resolved Resolved Closed Closed
        33d 5h 47m 1 Emmanuel Lecharny 20/Jun/13 11:12
        Emmanuel Lecharny made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Emmanuel Lecharny made changes -
        Fix Version/s 2.0.0-M13 [ 12324631 ]
        Fix Version/s 2.0.0-RC1 [ 12313387 ]
        Emmanuel Lecharny made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Emmanuel Lecharny added a comment -

        Since the report, the method has been greatly improved.

        Pierre-Arnaud Marcelot made changes -
        Fix Version/s 2.0.0-RC1 [ 12313387 ]
        Fix Version/s 2.0.0-M3 [ 12316467 ]
        Pierre-Arnaud Marcelot added a comment -

        Version 2.0.0-M3 has been released a couple months ago.

        Assigned the remaining opened JIRA to the next iteration (2.0.0-M4).

        Pierre-Arnaud Marcelot made changes -
        Fix Version/s 2.0.0-M3 [ 12316467 ]
        Fix Version/s 2.0.0-M2 [ 12316056 ]
        Pierre-Arnaud Marcelot added a comment -

        Version 2.0.0-M1 has been released.
        Moving all related non-resolved issues to the next version.

        Pierre-Arnaud Marcelot made changes -
        Fix Version/s 2.0.0-M2 [ 12316056 ]
        Fix Version/s 2.0.0-M1 [ 12316055 ]
        Pierre-Arnaud Marcelot added a comment -

        Version 2.0.0-M1 has been released.
        Moving all related non-resolved issues to the next version.

        Emmanuel Lecharny made changes -
        Field Original Value New Value
        Fix Version/s 2.0-M1 [ 12316055 ]
        Fix Version/s 2.0.0-RC1 [ 12313387 ]
        Emmanuel Lecharny created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Emmanuel Lecharny
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development