Directory ApacheDS
  1. Directory ApacheDS
  2. DIRSERVER-1336

lowercase m-may attributes change on LDIF import with Studio

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.5.4
    • Fix Version/s: 2.0.0-M1
    • Component/s: core
    • Labels:
      None
    • Environment:
      Windows Server 2003

      Description

      When I import LDIF file with Studio "import" function, attributes (m-may type) switch to lowercase.
      Example of LDIF file :

      dn: uid=048770,dc=personnes,dc=chs,dc=fr
      objectClass: organizationalPerson
      objectClass: person
      objectClass: inetOrgPerson
      objectClass: top
      cn: DUPONT Jean
      givenName: Jean
      mail: jdupont@test.fr
      sn: DUPONT
      uid: 048770

      Result import in LDAP :

      dn: uid=048770,dc=personnes,dc=chs,dc=fr
      objectClass: organizationalPerson
      objectClass: person
      objectClass: inetOrgPerson
      objectClass: top
      cn: DUPONT Jean
      givenname: Jean
      mail: jdupont@test.fr
      sn: DUPONT
      uid: 048770

      "ginvenName" become "givenname" ...
      Thanks and congratulation for Eclipse Community Awards 2009

        Activity

        Kiran Ayyagari added a comment -

        This is no longer reproducible on the current trunk, should have been fixed during the schema system rewrite.
        Note that the LDIF data exported after adding the entry maintains the case of attribute names. Marking as resolved.

        Delubac Benjamin added a comment -

        Thx, Can't test it for this moment, I have to resolve a Windows Service Error when I try to upgrade to 1.5.5.

        Apache DS Service don't want to start ...

        Carlo Accorsi added a comment -

        The 1.5.5 build fixed our issue. Thank you!!

        Emmanuel Lecharny added a comment -

        Postponed to the next release : The schema subsystem and Modify operatio are under a heavy refactoring, and 1.5.5. will be released without the patch. Next release is due for the next month, and this issue will be fixed as soon as the modify() refactoring will be done, something I'm working on atm.

        Emmanuel Lecharny added a comment -

        We are currently working on the Modify operation (on another bug). I will give a look at this issue as I'm familiar with the code, and give you a feedback soon.

        1.5.5 will probably be voted in the next few days, and release 3 days later, if the vote is positive. I hope we can get it out by the end of this week !

        Carlo Accorsi added a comment -

        We also have seen this issue while using a 3rd party Java LDAP api. Attributes that are removed and re-added or modified with a specfic case, are created lower case. For example when we initially create the entry, the attribute displayName comes in with the correct case. However, later if we modify the attribute, the case turns to displayname (all lowercase). This causes issues later in our application because the API is case sensitive. So searching for displayName=Smith* yields no results after the entry is modified.

        Question, the issues list says this is fixed in 1.5.5. Any ideas when this might become available? Otherwise, is there a patch that might be available in the interim? We appreciate this great product and look forward to getting this issue resolved. Thank you.

        Delubac Benjamin added a comment -

        OK, i'm waiting for this release !!

        Delubac Benjamin added a comment -

        I've shown this topic, but in my case, it appears on "modify" and "create" procedure.

        More over I don't understand how I can use the .java file linked in the topic (I'm on Windows machine) ...

        Thx (and sorry for my poor english)

        Stefan Seelmann added a comment -

        Could be related to DIRSERVER-1269, I'll check.

        Delubac Benjamin added a comment - - edited

        The only way i've find is to add elements in two times (I work in PHP) :

        • First, I add the m-must attributs (objectClass, cn ...)
        • Second, I add m-may attributs with ldap_mod_add() function

        $attributes["roleOccupant"][ ] = $dn;
        ldap_mod_add($ldap_link,$dn_root,$attribute);

        "roleOccupant" attributes have uppercase "O" in LDAP...

        Delubac Benjamin added a comment - - edited

        I've tested import LDIF with phpldapadmin, same issue ...

        I've export with Eclipse Studio and import the LDIF file previously exported, same issue ...

        Server Bug or LDIF format error ?


          People

          • Assignee:
            Emmanuel Lecharny
            Reporter:
            Delubac Benjamin
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 48h
              48h
              Remaining:
              Remaining Estimate - 48h
              48h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development