Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.5.4
    • Fix Version/s: 1.5.5
    • Component/s: changepw, ldap
    • Labels:
      None
    • Environment:
      AIX 5.2
      IBM JDK 1.5.0

      Description

      The following kerberos test fails on the IBM JDK.

      -------------------------------------------------------------------------------
      Test set: org.apache.directory.server.kerberos.kdc.SaslGssapiBindITest
      -------------------------------------------------------------------------------
      Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 15.396 sec <<< FAILURE!
      testSaslGssapiBind(org.apache.directory.server.kerberos.kdc.SaslGssapiBindITest) Time elapsed: 15.268 sec <<< ERROR!
      java.lang.RuntimeException: Failed to create KeyManagerFactory
      at org.apache.directory.server.ldap.handlers.extended.StartTlsHandler.setLdapServer(StartTlsHandler.java:164)
      at org.apache.directory.server.ldap.LdapService.startLDAP0(LdapService.java:417)
      at org.apache.directory.server.ldap.LdapService.start(LdapService.java:323)
      at org.apache.directory.server.unit.AbstractServerTest.setUp(AbstractServerTest.java:275)
      at org.apache.directory.server.kerberos.kdc.SaslGssapiBindITest.setUp(SaslGssapiBindITest.java:84)
      at junit.framework.TestCase.runBare(TestCase.java:132)
      at junit.framework.TestResult$1.protect(TestResult.java:110)
      at junit.framework.TestResult.runProtected(TestResult.java:128)
      at junit.framework.TestResult.run(TestResult.java:113)
      at junit.framework.TestCase.run(TestCase.java:124)
      at junit.framework.TestSuite.runTest(TestSuite.java:232)
      at junit.framework.TestSuite.run(TestSuite.java:227)
      at org.junit.internal.runners.JUnit38ClassRunner.run(JUnit38ClassRunner.java:81)
      at org.apache.maven.surefire.junit4.JUnit4TestSet.execute(JUnit4TestSet.java:62)
      at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.executeTestSet(AbstractDirectoryTestSuite.java:140)
      at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.execute(AbstractDirectoryTestSuite.java:127)
      at org.apache.maven.surefire.Surefire.run(Surefire.java:177)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:79)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:618)
      at org.apache.maven.surefire.booter.SurefireBooter.runSuitesInProcess(SurefireBooter.java:345)
      at org.apache.maven.surefire.booter.SurefireBooter.main(SurefireBooter.java:1009)
      Caused by: java.security.NoSuchAlgorithmException: SunX509 KeyManagerFactory not available
      at sun.security.jca.GetInstance.getInstance(GetInstance.java:158)
      at javax.net.ssl.KeyManagerFactory.getInstance(KeyManagerFactory.java:20)
      at org.apache.directory.server.ldap.handlers.extended.StartTlsHandler.setLdapServer(StartTlsHandler.java:160)
      ... 22 more

      1. DIRSERVER-1279.patch
        1 kB
        Jonathan Anstey

        Activity

        Jonathan Anstey created issue -
        Jonathan Anstey added a comment -

        Here's a simple patch to fix the issue. I just removed the hard coded reference to a Sun security provider with a dynamic call. Tested this fix on Linux (with Sun JDK) and AIX (with IBM JDK).

        Jonathan Anstey made changes -
        Field Original Value New Value
        Attachment DIRSERVER-1279.patch [ 12392477 ]
        Emmanuel Lecharny added a comment -

        Thanks ! We will apply the patch asap.

        Emmanuel Lecharny made changes -
        Assignee Emmanuel Lecharny [ elecharny ]
        Emmanuel Lecharny made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Emmanuel Lecharny added a comment -

        We have the exact same error in the LDAP server :

        String algorithm = Security.getProperty( "ssl.KeyManagerFactory.algorithm" );

        if ( algorithm == null )

        { algorithm = "SunX509"; }

        KeyManagerFactory kmf = KeyManagerFactory.getInstance( algorithm );

        Both errors will be fixed in 1.5.5

        Thanks for the patch !

        Jonathan Anstey added a comment -

        Excellent, thanks for applying the fix Emmanuel!

        Emmanuel Lecharny added a comment -

        FYI, the fix has been applied in a branch. When we will merge it with trunk, it will be available.

        And thank you for the patch !

        Emmanuel Lecharny added a comment -

        It has been fixed in the ads-mina2.0 branch, which will be merged with trunk as soon as MINA-2.0.0-M4 will be released (in one week)

        Emmanuel Lecharny made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Emmanuel Lecharny added a comment -

        closed

        Emmanuel Lecharny made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Christine Koppelt made changes -
        Component/s changepw [ 12310717 ]
        Component/s kerberos [ 12310716 ]

          People

          • Assignee:
            Emmanuel Lecharny
            Reporter:
            Jonathan Anstey
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development