Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.5.1
    • Fix Version/s: 2.0.0-M12
    • Component/s: None
    • Labels:
      None
    • Environment:
      apacheds-server-1.5.1-x86_64.rpm on RHEL5

      Description

      1. ldappasswd -a foobar -x -D 'uid=admin,ou=system'
        ldap_bind: Invalid credentials (49)
        additional info: Bind failed: null

      and the logfile says:
      INFO | jvm 1 | 2008/03/05 14:44:43 | [14:44:43] INFO [org.apache.directory.server.core.authn.SimpleAuthenticator] - Password not correct for user 'uid=admin,ou=system'
      INFO | jvm 1 | 2008/03/05 14:44:43 | [14:44:43] INFO [org.apache.directory.server.core.authn.AuthenticationService] - Authenticator class org.apache.directory.server.core.authn.SimpleAuthenticator failed to authenticate uid=admin,ou=system
      INFO | jvm 1 | 2008/03/05 14:44:43 | [14:44:43] INFO [org.apache.directory.server.core.authn.AuthenticationService] - Cannot bind to the server

      but the password is correct, using it with e.g. ldapsearch or ApacheDirectoryStudio works.

      The same problem occurs with a test-user, it's not specific to uid=admin

      Emmanuel L├ęcharny said in a mail to users@directory.apache.org:
      > The ldappasswd is using an extended request, described by RFC 3062.
      > I think we support this RFC, but it may be buggy

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              douglas Martin Schuster
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: