Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.5.1
    • Fix Version/s: 1.5.4
    • Component/s: changepw
    • Labels:
      None
    • Environment:
      Server running on Red Hat Linux 3.4.6-3
      Apache Directory Studio running on Windows XP pro

      Description

      With the default admin username (uid=admin, ou=system) and password, I am able to login using Directory Studio with both simple and DIGEST-MD5 (SASL) authentication methods. After following the instructions, in the Basic User's guide, for changing the admin password, I cannot login using the DIGEST-MD5 (SASL). I can still login with the simple authentication method and the new password.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        346d 19h 45m 1 Emmanuel Lecharny 02/Sep/08 17:44
        Resolved Resolved Closed Closed
        165d 21h 34m 1 Emmanuel Lecharny 15/Feb/09 14:18
        Emmanuel Lecharny made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Emmanuel Lecharny added a comment -

        closed

        Emmanuel Lecharny made changes -
        Resolution Cannot Reproduce [ 5 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Emmanuel Lecharny added a comment -

        I think it was a bug : you are not supposed to be able to login with the PLAIn and DIGEST_MD5 mechanism with the same password.

        I have tested it, and I can't login using the 'secret' password using SIMPLE authentication and DIGEST_MD5, which is what we expect the server to do.

        Alex Karasulu added a comment -

        Status? Can someone try this out. I think this was fixed when we removed the admin credentials from the server.xml. Just need someone to give this a try.

        Alex Karasulu made changes -
        Fix Version/s 1.5.4 [ 12313147 ]
        Fix Version/s 1.5.3 [ 12312693 ]
        Emmanuel Lecharny made changes -
        Fix Version/s 1.5.2 [ 12310793 ]
        Fix Version/s 1.5.3 [ 12312693 ]
        Emmanuel Lecharny added a comment -

        Postponed.

        Alex Karasulu added a comment -

        This should have gotten much better at least to fix now that the admin password management is less special (meaning locked in due to it being present in two places - server.xml and the DIT).

        Emmanuel Lecharny made changes -
        Field Original Value New Value
        Fix Version/s 1.5.2 [ 12310793 ]
        Emmanuel Lecharny added a comment -

        We should have a scenario to reproduce this issue, translate this scenario to a unit test, and then fix the issue.

        Ryan Swanstrom created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Ryan Swanstrom
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development