Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.5.1
    • Fix Version/s: 1.5.4
    • Component/s: changepw
    • Labels:
      None
    • Environment:
      Server running on Red Hat Linux 3.4.6-3
      Apache Directory Studio running on Windows XP pro

      Description

      With the default admin username (uid=admin, ou=system) and password, I am able to login using Directory Studio with both simple and DIGEST-MD5 (SASL) authentication methods. After following the instructions, in the Basic User's guide, for changing the admin password, I cannot login using the DIGEST-MD5 (SASL). I can still login with the simple authentication method and the new password.

        Activity

        Hide
        Emmanuel Lecharny added a comment -

        We should have a scenario to reproduce this issue, translate this scenario to a unit test, and then fix the issue.

        Show
        Emmanuel Lecharny added a comment - We should have a scenario to reproduce this issue, translate this scenario to a unit test, and then fix the issue.
        Hide
        Alex Karasulu added a comment -

        This should have gotten much better at least to fix now that the admin password management is less special (meaning locked in due to it being present in two places - server.xml and the DIT).

        Show
        Alex Karasulu added a comment - This should have gotten much better at least to fix now that the admin password management is less special (meaning locked in due to it being present in two places - server.xml and the DIT).
        Hide
        Emmanuel Lecharny added a comment -

        Postponed.

        Show
        Emmanuel Lecharny added a comment - Postponed.
        Hide
        Alex Karasulu added a comment -

        Status? Can someone try this out. I think this was fixed when we removed the admin credentials from the server.xml. Just need someone to give this a try.

        Show
        Alex Karasulu added a comment - Status? Can someone try this out. I think this was fixed when we removed the admin credentials from the server.xml. Just need someone to give this a try.
        Hide
        Emmanuel Lecharny added a comment -

        I think it was a bug : you are not supposed to be able to login with the PLAIn and DIGEST_MD5 mechanism with the same password.

        I have tested it, and I can't login using the 'secret' password using SIMPLE authentication and DIGEST_MD5, which is what we expect the server to do.

        Show
        Emmanuel Lecharny added a comment - I think it was a bug : you are not supposed to be able to login with the PLAIn and DIGEST_MD5 mechanism with the same password. I have tested it, and I can't login using the 'secret' password using SIMPLE authentication and DIGEST_MD5, which is what we expect the server to do.
        Hide
        Emmanuel Lecharny added a comment -

        closed

        Show
        Emmanuel Lecharny added a comment - closed

          People

          • Assignee:
            Unassigned
            Reporter:
            Ryan Swanstrom
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development