Directory ApacheDS
  1. Directory ApacheDS
  2. DIRSERVER-1049

[PERF] Speed improvement in Search operation

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.5.1
    • Fix Version/s: 2.0.0-M15
    • Component/s: core
    • Labels:
      None

      Description

      A search operation based on a single attribute, like (uid=user.123), should not pass through the optimizer at all, as we don't need to compute the number of entries.

      What we have now is that the search is built as a conjonction (AND) operation as if we have injected this filter :
      (& (objectclass =* ) (uid = user.123))

      The cost of doing such a count is not negligeable (5% of the overall operation)

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        2006d 8h 4m 1 Emmanuel Lecharny 26/Feb/13 10:08
        Resolved Resolved Closed Closed
        169d 15h 11m 1 Emmanuel Lecharny 15/Aug/13 02:19
        Emmanuel Lecharny made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Emmanuel Lecharny made changes -
        Fix Version/s 2.0.0-M15 [ 12324890 ]
        Fix Version/s 2.0.0-RC2 [ 12315095 ]
        Emmanuel Lecharny made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Emmanuel Lecharny added a comment -

        Fixed last week.

        Emmanuel Lecharny made changes -
        Fix Version/s 2.0.0-RC2 [ 12315095 ]
        Fix Version/s 2.0.0-RC1 [ 12313387 ]
        Emmanuel Lecharny added a comment -

        Potponed perf improvements to 2.0-RC2

        Emmanuel Lecharny made changes -
        Fix Version/s 2.0.0-RC1 [ 12313387 ]
        Fix Version/s 2.0.0 [ 12312396 ]
        Emmanuel Lecharny added a comment -

        Moved back to 2.0.0-RC1

        Emmanuel Lecharny made changes -
        Fix Version/s 2.0.0 [ 12312396 ]
        Fix Version/s 1.5.2 [ 12310793 ]
        Emmanuel Lecharny added a comment -

        PERF issues are postponed to 2.0 (even if we can fix them before)

        Emmanuel Lecharny made changes -
        Field Original Value New Value
        Summary Speed improvement in Search operation [PERF] Speed improvement in Search operation
        Issue Type Bug [ 1 ] Improvement [ 4 ]
        Emmanuel Lecharny added a comment -

        This is not a bug.

        Added a tag in the subject to be able to find all the PERF issues quickly

        Emmanuel Lecharny created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Emmanuel Lecharny
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development