MINA
  1. MINA
  2. DIRMINA-740

Serial Hardware Flow Control is not working

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-M6
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Very different behaviours seen on Linux and Windows environments. Issues may be related, or may just both coincidentally happen on hardware flow controlled ports.

      Description

      Linux machines:

      Attempting to connect to a device using hardware flow control (RTS/CTS) fails to accumulate any incoming data regardless of the FlowControl constant sent to the SerialAddress constructor.

      External program (old C++ version of same application) confirms device does respond to requests after port opened as 19200 8E1 with RTS/CTS flow control – Mina-based Java app fails to get any incoming data at all. [ This may be because it has not sent the data it thinks it has, as the far end will only respond, not initiate. ]

      Windows machines:

      Attempting to connect to a port using hardware flow control disables the port for subsequent connections during same execution. [ IOW, once a port is opened with hardware flow control turned on, no non-flow control protocol is possible on that port. ] This is especially bad if the hardware-flow-requiring device driver is attempted on a port connected to a device not matching the driver (as the proper driver will not be able to open the port ).

      This may or may not be two symptoms of the same root cause.

        Activity

        boB Gage added a comment -

        Verified. Julien's fix has fixed the Linux hardware flow control symptom completely.

        THANKS!!


          People

          • Assignee:
            Julien Vermillard
            Reporter:
            boB Gage
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development