Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      From the dev@safehaus.org mailing list where AsyncWeb currently is:

      (1) Trustin as the MINA chair needs to check that the software grant has
      been filed by the ASF Secretary after receiving it via fax from LogicaCMG.

      (2) The MINA TLP must complete the IP Clearance process to enable an
      import into their SVN repository:

      http://incubator.apache.org/ip-clearance/index.html

      HTH,
      Alex

      James Im wrote:
      > I'm afraid I don't understand the process (I'm not involved in it, just
      > curious).
      >
      > Who needs to do what now?

      > Alex Karasulu wrote:
      >> Cameron Taggart wrote:
      >>> Alex, did you receive the ASF release grant that Dave is referring to?
      >>> Isn't that that only thing keeping it from being moved over under
      >>> MINA?
      >>
      >> I reported the notification the LogicaCMG lawyers gave me then ping'd
      >> the MINA PMC to watch the software grants file for commits by the ASF
      >> secretary.
      >>
      >> My job was to make that happen. I think it has someone just needs to
      >> check the software grants file.
      >>
      >> Alex

        Activity

        trustin Trustin Lee added a comment -

        I will proceed after releasing MINA 1.0.2. I can't do two things at the same time.

        ctaggart Cameron Taggart added a comment -

        Trustin, I get really excited when I here you say such things...

        > I was able to get
        > performance test result as good as Apache HTTPD 2 with MINA 2.0.0-M1 +
        > AsyncWeb-trunk duo. My RAID is broken yesterday, so I will try to publish
        > the detailed performance test report when it gets back to life.

        Looking forward to the report and the import.

        ctaggart Cameron Taggart added a comment -

        Just seeing if there has been any movement on this... ? It has been a month since I last commented on it and MINA 1.0.2 came out on Feb 19. Any news or anything else blocking this import?

        Other people wish to know too.
        http://www.safehaus.org/pipermail/dev/2007-March/001220.html

        cheers,
        Cameron

        trustin Trustin Lee added a comment -

        It seems like the software grant has not been faxed yet. I asked the lawyer of LogicaCMG to fax the grant again.

        irvingd dave irving added a comment -

        Hi folks!

        Unfortunately Im still out-of-action (due to no PC at home, and in-ability to work on OSS stuff from work machines). However, Im starting a new job in a few weeks and once Im settled in I'll be getting stuck right back in to AsyncWeb (one day maybe I really will get round to working on content streaming...!!!).
        For now though, I believe the required legal signoff has been achieved, and if the import can take place without me then Im more than happy for this to go ahead.
        If not, Im happy to work on the import when I return from my drawn-out dormancy!!

        trustin Trustin Lee added a comment -

        Hi Dave! You are always welcome back! The software grant is confirmed. I will take care of this issue as soon as I'm back from honey moon

        irvingd dave irving added a comment -

        Hey everyone!

        Finally my link to the outside world has been restored, and Im back and ready for action!
        Is there anything I can do to help with this issue? It would be really good to finally get asyncweb to its new home :o)

        mheath Mike Heath added a comment -

        This template http://incubator.apache.org/ip-clearance/ip-clearance-template.html indicates that only Apache members and officers may execute IP clearance processing. With that being that case. What can I do to get this ball rolling? Would it be appropriate for me to fill out the template and attach it to this issue so that an Apache Member can actually submit it to the incubator?

        trustin Trustin Lee added a comment -

        We can import asyncweb directly into our trunk (or sandbox). Peter or I can take care of it. Let me raise the priority of this task in my personal to do list.

        mheath Mike Heath added a comment -

        From the issue description, I believe we have completed step (1) "Trustin as the MINA chair needs to check that the software grant has been filed by the ASF Secretary after receiving it via fax from LogicaCMG." We now need to do step (2) "The MINA TLP must complete the IP Clearance process to enable an import into their SVN repository: http://incubator.apache.org/ip-clearance/index.html" Step 2 needs to be done by an ASF member or officer.

        So, my understanding is that we can't import AsyncWeb until we get approval from the incubator. Am I understanding this process correctly?

        trustin Trustin Lee added a comment -

        Peter and I are Apache members. Apache members can fill the IP clearance form directly into the incubator web site and import the source code. Apache Directory project also imported TripleSec and many other products in the same manner.

        dandiep Dan Diephouse added a comment -

        Anyone still working on this?

        trustin Trustin Lee added a comment -

        AsyncWeb has been imported into the sandbox. It will be moved into trunk step by step (e.g. integration with existing client codec, module separation, package renaming)


          People

          • Assignee:
            trustin Trustin Lee
            Reporter:
            ctaggart Cameron Taggart
          • Votes:
            3 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development