Uploaded image for project: 'MINA'
  1. MINA
  2. DIRMINA-122

Initial IoFilterChain parameter in IoAcceptor.bind(...)

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 0.8.0
    • Fix Version/s: 0.9.0
    • Component/s: None
    • Labels:
      None

      Description

      There is no way to specify the initial IoFilterChain when a user binds his or her IoHandler. Users could add their filters in sessionCreated(), but it is sometimes inefficient because the filter should be added to all sessions. So we need these additional methods:

      • IoAcceptor.bind(SocketAddress, IoHandler, IoFilterChainFactory)
      • IoAcceptor.bind(SocketAddress, IoHandler, IoFilterChain)

      and two types:

      public interface IoFilterChainFactory
      {
      IoFilterChain getFilterChain();
      }

      public class <TBD> implements IoFilterChain {
      ....
      }

      Perhaps the second method can be implemented as an indirect call to the first method.

        Activity

        trustin Trustin Lee added a comment -

        This issue is a duplicate of DIRMINA-131


          People

          • Assignee:
            trustin Trustin Lee
            Reporter:
            trustin Trustin Lee
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development