Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.5
    • Fix Version/s: 3.0
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      It would be very advantageous for users to add a new processing instruction
      that we can use to self reference XML or other files from within a source that
      will be bound.

      For example

      <?xml version=”1.0” ?>
      <?binding-rules source=”org/apache/jakarta/commons/digester/myrules.xml” ?>
      <a>
      ……
      </a>

      This way we can change target objects and runtime binding just by editing the
      xml file with rules or editing separate rules.

      The rules should be available via multiple sources:
      ClassLoader
      File
      URL
      Custom

        Activity

        Simone Tripodi added a comment -

        included in Apache Commons Digester 3.0 release

        Simone Tripodi added a comment -

        <include /> element in xmlrules has been already supported for a long time in Digester

        rdonkin@apache.org added a comment -

        We should add support for processing instructions to Digester (it's one of the few missing bits).

        This isn't an itch for me but I'd probably be willing to take a look at a patch if anyone cares enough to
        contribute an implementation

        Simon Kitching added a comment -
            • COM-1524 has been marked as a duplicate of this bug. ***

          People

          • Assignee:
            Simone Tripodi
            Reporter:
            Michail Medvinsky
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development