Commons Digester
  1. Commons Digester
  2. DIGESTER-25

Invalid bean setters do not generate an exception

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      Operating System: other
      Platform: All

      Description

      In particular, when using the addBeanPropertySetter method of the Digester (but
      probably with other similar methods). The second parameter describes the name of
      the bean property from which the setter method is generated. If this method is
      not present in the bean, Digester does NOT generate any kind of exception or
      notification. This is easily done by (for example) using an upper case charater
      in place of a lower for the bean property name.

      Digester should generate and exception when a rule is fired, and the bean setter
      method is not found in the bean.

        Activity

        Craig McClanahan added a comment -

        Fixed BeanPropertySetterRule and SetPropertyRule so that they can still set
        write-only properties, which the previous fix broke. Corrected code will be
        available in nightly build 20030205, as well as upcoming 1.4.1 release.

        Craig McClanahan added a comment -

        It turns out that this fix causes problems for write-only properties. Reopening
        so we can document when that problem is repaired.

        Kenneth Baltz added a comment -
            • COM-352 has been marked as a duplicate of this bug. ***
        Craig McClanahan added a comment -

        Fixed in nightly build 20030119, which will be included in commons-digester 1.4.

        The same problem existed with SetPropertyRule, so I fixed it there as well.


          People

          • Assignee:
            Unassigned
            Reporter:
            Howard Miller
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development