Derby
  1. Derby
  2. DERBY-800

derbylang/ConcurrentImplicitCreateSchema.java fails intermittently with a lock timeout

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 10.2.1.6
    • Fix Version/s: 10.1.3.1, 10.2.1.6
    • Component/s: Test
    • Labels:
      None
    • Bug behavior facts:
      Regression Test Failure

      Description

      I have seen ConcurrentImplicitCreateSchema.java get a lock timeout periodically and it occurred in the posted sun tests for build 365391

      http://www.multinet.no/~solberg/public/Apache/Derby/testlog/CYGWIN_NT-5.2_i686-unknown/365391-derbylang_diff.txt
      (I don't know how long this link will last. Below is the diff)

                      • Diff file derbylang/derbylang/ConcurrentImplicitCreateSchema.diff
          • Start: ConcurrentImplicitCreateSchema jdk1.5.0_04 derbylang:derbylang 2006-01-02 20:03:09 ***
            2 del
            < Closed connection
            3 del
            < Test ConcurrentImplicitCreateSchema PASSED
            3 add
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requestedSQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > at org.apache.derby.impl.jdbc.EmbedStatement.execute(EmbedStatement.java:480)SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > at org.apache.derby.impl.jdbc.EmbedStatement.execute(EmbedStatement.java:550)SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > at org.apache.derby.impl.store.access.btree.index.B2IRowLocking3._lockScan(B2IRowLocking3.java:135)SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requestedSQL Exception: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > at org.apache.derby.iapi.error.StandardException.newException(StandardException.java:301)SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > at org.apache.derby.impl.store.access.btree.BTreeScan.next(BTreeScan.java:1696)SQL Exception: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requestedSQL Exception: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > at org.apache.derby.impl.store.access.btree.BTreeScan.positionAtStartForForwardScan(BTreeScan.java:441)SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > at org.apache.derby.impl.sql.catalog.DataDictionaryImpl.getColumnDescriptorsScan(DataDictionaryImpl.java:2259)SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > SQL Exception: A lock could not be obtained within the time requested
            > ERROR 40XL1: A lock could not be obtained within the time requested
            > Closed connection
            > Test ConcurrentImplicitCreateSchema FAILED
            Test Failed.
      1. derby-800.diff
        1 kB
        Øystein Grøvlen

        Activity

        Bernt M. Johnsen added a comment -

        Committed revision 406881 on 10.1 branch

        Bernt M. Johnsen added a comment -

        Merging to 10.1-branch

        Manjula Kutty added a comment -

        The same test fails with 10.1 with the same diff. Can you please remove it from 10.1 also?

        Øystein Grøvlen added a comment -

        Verified that test has been removed from derbyall.

        Bernt M. Johnsen added a comment -

        Committed revision 379733.

        Øystein Grøvlen added a comment -

        Attached derby-800.diff which removes lang/ConcurrentImplicitCreateSchema.java from derbyall.
        Files that are changed:

        M java/testing/org/apache/derbyTesting/functionTests/suites/derbylang.runall
        M java/testing/org/apache/derbyTesting/functionTests/suites/derbynetmats.runall

        Øystein Grøvlen added a comment -

        What I have done with this issue is that I have run the test with some
        tracing to see what caused the lock timeouts. I have not quite got to
        the bottom of it, but so far it seems to me that it is not a deadlock
        scenario, but just timeouts due to long queues on the dictionary lock.
        (See below for more info).

        Since creating 100 tables in parallel is not a common scenario, I am
        not sure whether it is worth the effort to attempt fix this so the
        test runs cleanly. ( The test was made to test a fix (Derby-230) that
        I do not think is very likely to reoccur.) I have suggested on
        derby-dev take we should just remove the test from derbyall. No one
        has protested so I will create a patch to do that.

        Mike Matrigali added a comment -

        I saw this test again fail in a 1/27 build, 372871. Definitely intermittent as many runs do succeeed.
        Here is the environment (i believe this is a slowish single processor machine):
        Generating report for RunSuite derbynetmats null null DerbyNet true
        ------------------ Java Information ------------------
        Java Version: 1.4.2_07
        Java Vendor: Sun Microsystems Inc.
        Java home: d:\dev\src\jdk142\jre
        Java classpath: d:/dev/src/classes/derby.jar;d:/dev/src/classes/derbytools.jar;d:/dev/src/classes/derbynet.jar;d:/dev/src/classes/derbyclient.jar;d:/dev/src/classes/functionTests.jar;d:/dev/src/classes/derbyTesting.jar;d:/dev/src/tools/java/jndi/fscontext.jar;d:/dev/src/drda/jcc/2.4_latest/db2jcc.jar;d:/dev/src/drda/jcc/2.4_latest/db2jcc_license_c.jar;d:/dev/src/tools/java/junit.jar;d:/dev/src/classes/derbyLocale_zh_TW.jar;d:/dev/src/classes/derbyLocale_zh_CN.jar;d:/dev/src/classes/derbyLocale_pt_BR.jar;d:/dev/src/classes/derbyLocale_ko_KR.jar;d:/dev/src/classes/derbyLocale_ja_JP.jar;d:/dev/src/classes/derbyLocale_it.jar;d:/dev/src/classes/derbyLocale_fr.jar;d:/dev/src/classes/derbyLocale_es.jar;d:/dev/src/classes/derbyLocale_de_DE.jar;
        OS name: Windows 2000
        OS architecture: x86
        OS version: 5.0
        Java user name: cloudtst
        Java user home: C:\Documents and Settings\cloudtst
        Java user dir: D:\dev\src\JarResults.2006-01-27\jdk142_derbynetmats_jcc_2.4_latest
        java.specification.name: Java Platform API Specification
        java.specification.version: 1.4

        And the diff:

            • Start: ConcurrentImplicitCreateSchema jdk1.4.2_07 DerbyNet derbynetmats:derbynetmats 2006-01-28 21:26:42 ***
              2 del
              < Closed connection
              3 del
              < Test ConcurrentImplicitCreateSchema PASSED
              3 add
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained due to a deadlock, cycle of locks and waiters is:
              > Lock : LATCH, SYSTABLES, Page(1,Container(0, 113))
              > Waiting XID : {WWW,QQQ} , APP, drop table testschema0.testtab21
              > Granted XID : {GGG.QQQ}...
              > Lock : LATCH, SYSTABLES, Page(2,Container(0, 113))
              > Waiting XID : {WWW,QQQ}

              , APP, drop table testschema0.testtab19
              > Granted XID :

              {GGG.QQQ}...
              > Lock : ROW, SYSTABLES, (3,1)
              > Waiting XID : {WWW,QQQ} , APP, drop table testschema0.testtab2
              > Granted XID : {GGG.QQQ}

              ...
              > . The selected victim is XID : 402.
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requestedcom.ibm.db2.jcc.a.SqlException: A lock could not be obtained due to a deadlock, cycle of locks and waiters is:
              > Lock : LATCH, SYSTABLES, Page(1,Container(0, 113))
              > Waiting XID :

              {WWW,QQQ} , APP, drop table testschema0.testtab36
              > Granted XID : {GGG.QQQ}...
              > Lock : LATCH, SYSTABLES, Page(2,Container(0, 113))
              > Waiting XID : {WWW,QQQ}


              > Granted XID :

              {GGG.QQQ}...
              > Lock : ROW, SYSTABLES, (3,1)
              > Waiting XID : {WWW,QQQ}
              > Granted XID : {GGG.QQQ}

              ...
              > . The selected victim is XID : 395.
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained within the time requested
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained due to a deadlock, cycle of locks and waiters is:
              > Lock : LATCH, SYSTABLES, Page(1,Container(0, 113))
              > Waiting XID :

              {WWW,QQQ} , APP, drop table testschema0.testtab21
              > Granted XID : {GGG.QQQ}...
              > Lock : LATCH, SYSTABLES, Page(2,Container(0, 113))
              > Waiting XID : {WWW,QQQ}

              , APP, drop table testschema0.testtab19
              > Granted XID :

              {GGG.QQQ}...
              > Lock : ROW, SYSTABLES, (3,1)
              > Waiting XID : {WWW,QQQ} , APP, drop table testschema0.testtab2
              > Granted XID : {GGG.QQQ}

              ...
              > . The selected victim is XID : 402.
              > com.ibm.db2.jcc.a.SqlException: A lock could not be obtained due to a deadlock, cycle of locks and waiters is:
              > Lock : LATCH, SYSTABLES, Page(1,Container(0, 113))
              > Waiting XID :

              {WWW,QQQ} , APP, drop table testschema0.testtab36
              > Granted XID : {GGG.QQQ}...
              > Lock : LATCH, SYSTABLES, Page(2,Container(0, 113))
              > Waiting XID : {WWW,QQQ}


              > Granted XID :

              {GGG.QQQ}...
              > Lock : ROW, SYSTABLES, (3,1)
              > Waiting XID : {WWW,QQQ}
              > Granted XID : {GGG.QQQ}

              ...
              > . The selected victim is XID : 395.
              > Closed connection
              > Test ConcurrentImplicitCreateSchema FAILED
              Test Failed.

        Mike Matrigali added a comment -

        adding to regression suite and raising priority as discussed for regression suite bugs.


          People

          • Assignee:
            Øystein Grøvlen
            Reporter:
            Kathey Marsden
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development