Uploaded image for project: 'Derby'
  1. Derby
  2. DERBY-6854

Make it possible to run Derby tests on early access versions of JDK 9

Attach filesAttach ScreenshotAdd voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 10.12.1.1
    • Fix Version/s: None
    • Component/s: Build tools
    • Labels:
      None
    • Urgency:
      Normal

      Description

      Early access versions of JDK 9 (build 100) have "9-ea" as the java.version and "9" as the java.specification.version. This confuses the JavaVersionHolder class which the regression tests use in order to determine the vm level. At a minimum, we need to make JavaVersionHolder recognize these early access strings.

      This issue can be left open even after a fix is applied because we have no idea how java.version and java.specification.version are going to evolve over the remaining development cycle for JDK 9.

        Attachments

        Issue Links

          Activity

            People

            • Assignee:
              rhillegas Richard N. Hillegas
              Reporter:
              rhillegas Richard N. Hillegas

              Dates

              • Created:
                Updated:

                Issue deployment