Uploaded image for project: 'Derby'
  1. Derby
  2. DERBY-6698

Make it easier to run suites.All on soft-upgraded database

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Test
    • Labels:
      None

      Description

      See discussion here: http://mail-archives.apache.org/mod_mbox/db-derby-dev/201408.mbox/%3C53E3B191.2010608%40gmail.com%3E

      It would be useful if tests that know they will fail unless the database format is at least at a certain version, disable themselves when running on an older database. This would reduce the noise when running suites.All on a soft-upgraded database, which is an ad hoc test that's sometimes performed during release testing.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                knutanders Knut Anders Hatlen
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: