Uploaded image for project: 'Derby'
  1. Derby
  2. DERBY-6513

Warnings when building 10.10 branch with Java 8

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 10.10.2.0
    • 10.9.2.2, 10.10.2.0
    • Build tools
    • None
    • java version "1.8.0"
      Java(TM) SE Runtime Environment (build 1.8.0-b128)
      Java HotSpot(TM) 64-Bit Server VM (build 25.0-b69, mixed mode)
      Mac OSX 10.7.5
    • Normal

    Description

      When I build the 10.10 branch using JDK 8, I see the following warnings:

          [javac] warning: [options] source value 1.4 is obsolete and will be removed in a future release
          [javac] warning: [options] target value 1.4 is obsolete and will be removed in a future release
          [javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
          [javac] 3 warnings
      

      Attachments

        1. derby-6513-01-aa-suppressWarnings.diff
          2 kB
          Richard N. Hillegas

        Activity

          People

            rhillegas Richard N. Hillegas
            rhillegas Richard N. Hillegas
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: