Derby
  1. Derby
  2. DERBY-61

Some derby javadoc issues should be cleaned up

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Duplicate
    • Affects Version/s: 10.0.2.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      I noticed these javadoc errors in the engine javadoc build which should be cleaned up.

      [javadoc] D:\dev\src\html\sourcedir\org\apache\derby\jdbc\EmbeddedConnectionPoolDataSource.java:81: warning - @param argument "user" is not a parameter name.
      [javadoc] D:\dev\src\html\sourcedir\org\apache\derby\jdbc\EmbeddedDataSource.java:417: warning - @param argument "user" is not a parameter name.
      [javadoc] 2 warnings

      [javadoc] D:\dev\src\opensource\java\engine\org\apache\derby\impl\sql\compile\AggregateDefinition.java:44: warning - Tag @see: can't find getTypeFactory in org.apache.derby.iapi.db.Factory
      [javadoc] D:\dev\src\opensource\java\engine\org\apache\derby\iapi\services\classfile\ClassHolder.java:303: warning - Tag @see: can't find addInteger in org.apache.derby.iapi.services.classfile.ClassHolder
      [javadoc] D:\dev\src\opensource\java\engine\org\apache\derby\iapi\services\classfile\ClassHolder.java:308: warning - Tag @see: can't find addFloat in org.apache.derby.iapi.services.classfile.ClassHolder
      [javadoc] D:\dev\src\opensource\java\engine\org\apache\derby\iapi\services\classfile\ClassHolder.java:313: warning - Tag @see: can't find addLong in org.apache.derby.iapi.services.classfile.ClassHolder
      [javadoc] D:\dev\src\opensource\java\engine\org\apache\derby\iapi\services\classfile\ClassHolder.java:318: warning - Tag @see: can't find addDouble in org.apache.derby.iapi.services.classfile.ClassHolder
      [javadoc] D:\dev\src\opensource\java\engine\org\apache\derby\iapi\reference\Property.java:586: warning - Tag @see: can't find checkpoint in org.apache.derby.iapi.reference.Property
      [javadoc] D:\dev\src\opensource\java\engine\org\apache\derby\catalog\types\MethodAliasInfo.java:113: warning - Tag @see: can't find getTargetClassName in org.apache.derby.catalog.AliasInfo
      [javadoc] D:\dev\src\opensource\java\engine\org\apache\derby\catalog\types\MethodAliasInfo.java:120: warning - Tag @see: can't find getTargetMethodName in org.apache.derby.catalog.AliasInfo
      [javadoc] D:\dev\src\opensource\java\engine\org\apache\derby\iapi\reference\Property.java:592: warning - Tag @see: can't find logArchived in org.apache.derby.iapi.reference.Property
      [javadoc] D:\dev\src\opensource\java\engine\org\apache\derby\iapi\reference\Property.java:580: warning - Tag @see: can't find checkpoint in org.apache.derby.iapi.reference.Property
      [javadoc] D:\dev\src\opensource\java\drda\org\apache\derby\impl\drda\DB2jServerImpl.java:913: warning - Tag @see: can't find runtimeinfo in org.apache.derby.drda.NetworkServerControl
      [javadoc] D:\dev\src\opensource\java\engine\org\apache\derby\iapi\sql\dictionary\SchemaDescriptor.java:103: warning - Tag @see: can't find getDefaultSchemaName in org.apache.derby.impl.sql.conn.GenericLanguageConnectionContext
      [javadoc] D:\dev\src\opensource\java\engine\org\apache\derby\catalog\TypeDescriptor.java:57: warning - Tag @see: reference not found: Types
      [javadoc] D:\dev\src\opensource\java\engine\org\apache\derby\catalog\SystemProcedures.java:76: warning - @param argument "errd0-5" is not a parameter name.
      [javadoc] D:\dev\src\opensource\java\engine\org\apache\derby\catalog\SystemProcedures.java:157: warning - @param argument "resultset" is not a parameter name.

        Issue Links

          Activity

          Kathey Marsden added a comment -

          Closing this as a Duplicate to Derby-204. This bug was filed first, but Derby-204 has a better description as this bug just lists a few specific
          javadoc warnings.

          Kathey Marsden added a comment -

          This issue is being tracked as DERBY-204

          Kathey Marsden added a comment -

          duplicate of DERBY-204


            People

            • Assignee:
              Unassigned
              Reporter:
              Kathey Marsden
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development