Derby
  1. Derby
  2. DERBY-6058

2 ClassNotFoundException failures on trunk with ibm's weme6.2 since build 1433263

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.10.1.1
    • Fix Version/s: 10.10.1.1
    • Component/s: Test
    • Labels:
      None
    • Environment:
      windows xp with ibm's cdc/foundation implementation weme6.2.

      Description

      Since the build of 1433263 on trunk, we see the following test failures:

      1) noSpecialCollation(org.apache.derbyTesting.functionTests.tests.lang.TableFunctionTest)java.sql.SQLException: The class 'org.apache.derbyTesting.functionTests.tests.lang.VarargsRoutines' does not exist or is inaccessible. This can happen if the class is not public.
      at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.seeNextException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.ConnectionChild.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedPreparedStatement.<init>(Unknown Source)
      at org.apache.derby.jdbc.Driver169.newEmbedPreparedStatement(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.prepareStatement(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.prepareStatement(Unknown Source)
      at org.apache.derbyTesting.junit.BaseJDBCTestCase.prepareStatement(BaseJDBCTestCase.java:217)
      at org.apache.derbyTesting.functionTests.tests.lang.TableFunctionTest.assertResults(TableFunctionTest.java:2579)
      at org.apache.derbyTesting.functionTests.tests.lang.TableFunctionTest.assertResults(TableFunctionTest.java:2568)
      at org.apache.derbyTesting.functionTests.tests.lang.TableFunctionTest.derby_6040(TableFunctionTest.java:2370)
      at org.apache.derbyTesting.functionTests.tests.lang.TableFunctionTest.miscBugs(TableFunctionTest.java:1936)
      at org.apache.derbyTesting.functionTests.tests.lang.TableFunctionTest.tableFunctionTest(TableFunctionTest.java:1005)
      at org.apache.derbyTesting.functionTests.tests.lang.TableFunctionTest.noSpecialCollation(TableFunctionTest.java:971)
      at java.lang.reflect.AccessibleObject.invokeV(AccessibleObject.java:195)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:117)
      at org.apache.derbyTesting.junit.BaseJDBCTestCase.runBareOverridable(BaseJDBCTestCase.java:424)
      at org.apache.derbyTesting.junit.BaseJDBCTestCase.runBare(BaseJDBCTestCase.java:441)
      Caused by: java.sql.SQLException: Java exception: 'org.apache.derbyTesting.functionTests.tests.lang.VarargsRoutines : JVMCFRE003 bad major version; class=org/apache/derbyTesting/functionTests/tests/lang/VarargsRoutines, offset=6: java.lang.ClassNotFoundException'.
      at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.javaException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unknown Source)
      ... 37 more
      Caused by: java.lang.ClassNotFoundException: org.apache.derbyTesting.functionTests.tests.lang.VarargsRoutines : JVMCFRE003 bad major version; class=org/apache/derbyTesting/functionTests/tests/lang/VarargsRoutines, offset=6
      at org.apache.derby.impl.services.reflect.DatabaseClasses.loadApplicationClass(Unknown Source)
      at org.apache.derby.iapi.services.loader.ClassInspector.getClass(Unknown Source)
      at org.apache.derby.iapi.services.loader.ClassInspector.accessible(Unknown Source)
      at org.apache.derby.impl.sql.compile.QueryTreeNode.verifyClassExist(Unknown Source)
      at org.apache.derby.impl.sql.compile.StaticMethodCallNode.bindExpression(Unknown Source)
      at org.apache.derby.impl.sql.compile.FromVTI.bindVTITables(Unknown Source)
      at org.apache.derby.impl.sql.compile.FromList.bindTables(Unknown Source)
      at org.apache.derby.impl.sql.compile.SelectNode.bindNonVTITables(Unknown Source)
      at org.apache.derby.impl.sql.compile.DMLStatementNode.bindTables(Unknown Source)
      at org.apache.derby.impl.sql.compile.DMLStatementNode.bind(Unknown Source)
      at org.apache.derby.impl.sql.compile.CursorNode.bindStatement(Unknown Source)
      at org.apache.derby.impl.sql.GenericStatement.prepMinion(Unknown Source)
      at org.apache.derby.impl.sql.GenericStatement.prepare(Unknown Source)
      at org.apache.derby.impl.sql.conn.GenericLanguageConnectionContext.prepareInternalStatement(Unknown Source)
      ... 33 more
      2) specialCollation(org.apache.derbyTesting.functionTests.tests.lang.TableFunctionTest)java.sql.SQLException: The class 'org.apache.derbyTesting.functionTests.tests.lang.VarargsRoutines' does not exist or is inaccessible. This can happen if the class is not public.
      at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.seeNextException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.ConnectionChild.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedPreparedStatement.<init>(Unknown Source)
      at org.apache.derby.jdbc.Driver169.newEmbedPreparedStatement(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.prepareStatement(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.prepareStatement(Unknown Source)
      at org.apache.derbyTesting.junit.BaseJDBCTestCase.prepareStatement(BaseJDBCTestCase.java:217)
      at org.apache.derbyTesting.functionTests.tests.lang.TableFunctionTest.assertResults(TableFunctionTest.java:2579)
      at org.apache.derbyTesting.functionTests.tests.lang.TableFunctionTest.assertResults(TableFunctionTest.java:2568)
      at org.apache.derbyTesting.functionTests.tests.lang.TableFunctionTest.derby_6040(TableFunctionTest.java:2370)
      at org.apache.derbyTesting.functionTests.tests.lang.TableFunctionTest.miscBugs(TableFunctionTest.java:1936)
      at org.apache.derbyTesting.functionTests.tests.lang.TableFunctionTest.tableFunctionTest(TableFunctionTest.java:1005)
      at org.apache.derbyTesting.functionTests.tests.lang.TableFunctionTest.specialCollation(TableFunctionTest.java:981)
      at java.lang.reflect.AccessibleObject.invokeV(AccessibleObject.java:195)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:117)
      at org.apache.derbyTesting.junit.BaseJDBCTestCase.runBareOverridable(BaseJDBCTestCase.java:424)
      at org.apache.derbyTesting.junit.BaseJDBCTestCase.runBare(BaseJDBCTestCase.java:441)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      Caused by: java.sql.SQLException: Java exception: 'org.apache.derbyTesting.functionTests.tests.lang.VarargsRoutines : JVMCFRE003 bad major version; class=org/apache/derbyTesting/functionTests/tests/lang/VarargsRoutines, offset=6: java.lang.ClassNotFoundException'.
      at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.javaException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unknown Source)
      ... 52 more
      Caused by: java.lang.ClassNotFoundException: org.apache.derbyTesting.functionTests.tests.lang.VarargsRoutines : JVMCFRE003 bad major version; class=org/apache/derbyTesting/functionTests/tests/lang/VarargsRoutines, offset=6
      at org.apache.derby.impl.services.reflect.DatabaseClasses.loadApplicationClass(Unknown Source)
      at org.apache.derby.iapi.services.loader.ClassInspector.getClass(Unknown Source)
      at org.apache.derby.iapi.services.loader.ClassInspector.accessible(Unknown Source)
      at org.apache.derby.impl.sql.compile.QueryTreeNode.verifyClassExist(Unknown Source)
      at org.apache.derby.impl.sql.compile.StaticMethodCallNode.bindExpression(Unknown Source)
      at org.apache.derby.impl.sql.compile.FromVTI.bindVTITables(Unknown Source)
      at org.apache.derby.impl.sql.compile.FromList.bindTables(Unknown Source)
      at org.apache.derby.impl.sql.compile.SelectNode.bindNonVTITables(Unknown Source)
      at org.apache.derby.impl.sql.compile.DMLStatementNode.bindTables(Unknown Source)
      at org.apache.derby.impl.sql.compile.DMLStatementNode.bind(Unknown Source)
      at org.apache.derby.impl.sql.compile.CursorNode.bindStatement(Unknown Source)
      at org.apache.derby.impl.sql.GenericStatement.prepMinion(Unknown Source)
      at org.apache.derby.impl.sql.GenericStatement.prepare(Unknown Source)
      at org.apache.derby.impl.sql.conn.GenericLanguageConnectionContext.prepareInternalStatement(Unknown Source)
      ... 48 more

      Things were fine with build 1432788.
      Things are also fine with ibm 1.5, 1.6, 1.7.

      See also: http://people.apache.org/~myrnavl/derby_test_results/main/windows/testSummary-1433263.html

        Issue Links

          Activity

          Rick Hillegas added a comment -

          Linking to DERBY-6040 because the failing test was introduced by work on that issue.

          Rick Hillegas added a comment -

          Thanks for finding this problem, Myrna. Attaching derby-6058-01-aa-disableOnJSR169.diff. This patch disables the failing test on JSR169. Committed at subversion revision 1439889.

          The failing test uses a varargs table function which only runs on VM level 5 and above.

          Before applying this patch, the test failed for me on OJEC. After applying the patch, the test succeeds on OJEC.

          Touches the following file:

          M java/testing/org/apache/derbyTesting/functionTests/tests/lang/TableFunctionTest.java


            People

            • Assignee:
              Rick Hillegas
              Reporter:
              Myrna van Lunteren
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development