Derby
  1. Derby
  2. DERBY-5814

Source cleanup in catalogs "impl.sql.catalog" and "impl.sql.compile"

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 10.10.1.1
    • Component/s: SQL
    • Labels:
      None

      Description

      A patch which clean up sources as follows:

      a) removed unused private methods
      b) removed unused local variables and members
      c) cleaned up imports
      d) remove unused formal arguments

      A repercussion of a d) gave simplifications in sqlgrammar.jj

      1. catalog-compile-cleaning.diff
        30 kB
        Dag H. Wanvik
      2. catalog-compile-cleaning-2.diff
        30 kB
        Dag H. Wanvik
      3. catalog-compile-cleaning-2.stat
        0.6 kB
        Dag H. Wanvik

        Activity

        Dag H. Wanvik added a comment -

        Regressions passed with these changes.

        Knut Anders Hatlen added a comment -

        Looks like a good cleanup.

        FromVTI.markUpdatableByCursor() now only forwards to its super class. Remove and rely on inheritance?

        Dag H. Wanvik added a comment -

        Thanks, Knut! Yup, I'll do that.

        Dag H. Wanvik added a comment - - edited

        Uploading version 2 with Knut's suggestion plus some further whitespace cleanups (only in those lines I touched anyway).

        Dag H. Wanvik added a comment - - edited

        Ran the VTI tests over again, committed as svn 1350289, closing.


          People

          • Assignee:
            Dag H. Wanvik
            Reporter:
            Dag H. Wanvik
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development