Derby
  1. Derby
  2. DERBY-5468

Assertion failed in AutomaticIndexStatisticsMultiTest.testMTSelectWithDDL (expected:<0> but was:<1>)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 10.8.2.2
    • Fix Version/s: None
    • Component/s: Test
    • Urgency:
      Low
    • Bug behavior facts:
      Regression Test Failure

      Description

      Seen when testing the 10.8.2.2 release candidate:

      http://dbtg.foundry.sun.com/derby/test/10.8.2.2_RC/logs/jvm1.5/sol32/suitesAll/report.txt

      1) testMTSelectWithDDL(org.apache.derbyTesting.functionTests.tests.store.AutomaticIndexStatisticsMultiTest)junit.framework.AssertionFailedError: expected:<0> but was:<1>
      at org.apache.derbyTesting.functionTests.tests.store.AutomaticIndexStatisticsMultiTest.testMTSelectWithDDL(AutomaticIndexStatisticsMultiTest.java:133)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:113)

        Activity

        Knut Anders Hatlen created issue -
        Kristian Waagan added a comment -

        Attaching patch 1a, which improves the error reporting. I plan to backport this to 10.8 once it has been committed on trunk.

        Patch ready for review.

        Is an error reported in derby.log? Maybe it includes a stack trace (search for the test name or the runnable).

        Kristian Waagan made changes -
        Field Original Value New Value
        Attachment derby-5468-1a-error_reporting.diff [ 12499364 ]
        Kristian Waagan made changes -
        Issue & fix info Patch Available [ 10102 ]
        Knut Anders Hatlen added a comment -

        +1 to the improved reporting.

        There were no stack traces in derby.log. The test ran with insane jars, so only the most severe errors are logged by default.

        Kristian Waagan added a comment -

        Committed the updated patch 1a to trunk with revision 1185187. The only difference from the first patch is that I removed an assert that I forgot the first time around.

        I'll let it run for a day before backporting.

        Knut Anders, do you have a take on how easy is it to reproduce the error on the 10.8 branch?

        Kristian Waagan made changes -
        Attachment derby-5468-1a-error_reporting.diff [ 12499373 ]
        Kristian Waagan made changes -
        Attachment derby-5468-1a-error_reporting.diff [ 12499364 ]
        Knut Anders Hatlen added a comment -

        I don't know. I've only seen it once. I have it running in a loop now on the machine where the failure was seen, using the same JVM (1.5), but nothing so far. I'll just let it run for a while.

        Knut Anders Hatlen added a comment -

        Over 300 iterations now, and still no failure...

        Kristian Waagan made changes -
        Issue & fix info Patch Available [ 10102 ]
        Myrna van Lunteren added a comment -

        I am assuming this didn't pop and Knut has stopped looping this test (last comment was almost a year ago). I don't think I've ever seen this failure myself.

        Looks like the patch was applied with revision 1185187.

        Shall we close this as 'Can not Reproduce'?

        Myrna van Lunteren made changes -
        Labels derby_triage10_10
        Urgency Low [ 10053 ]
        Knut Anders Hatlen added a comment -

        I don't think this failure was seen more than once. Closing the issue as not reproducible.

        Knut Anders Hatlen made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Cannot Reproduce [ 5 ]
        Gavin made changes -
        Workflow jira [ 12638033 ] Default workflow, editable Closed status [ 12797112 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Knut Anders Hatlen
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development