Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.8.1.2
    • Fix Version/s: 10.8.1.2
    • Component/s: Services
    • Labels:
      None

      Description

      The automatic index statistics daemon will by default log what it's doing. That means messages like these ones will be written to derby.log during normal operation:

      Wed Mar 02 13:36:22 CET 2011 Thread[main,5,main]

      {istat} "APP"."T": update scheduled - 23ce809c-012e-7691-6c29-000003480128 reason=[no stats, row-estimate=36167] (queueSize=1)
      Wed Mar 02 13:36:22 CET 2011 Thread[index-stat-thread,5,main] {istat}

      "APP"."T": generating index statistics
      Wed Mar 02 13:36:23 CET 2011 Thread[index-stat-thread,5,main]

      {istat} "APP"."T": generation complete (509 ms)
      Wed Mar 02 13:36:23 CET 2011 Thread[main,5,main] {istat}

      stopping daemon, active=false, work/age=510/14736 [q/p/s=0/1/1,err:k/u/c=0/0/0,rej:f/d/o=0/0/0]

      Although these messages may be helpful in diagnosing bugs, they may also be a source of confusion since users probably only expect errors/problems to be logged by default. Also, for some workloads, large quantities of log may be produced and take up disk space. Therefore, I think we should disable the logging before the 10.8 release, and instead instruct users who experience problems to enable logging manually with the derby.storage.indexStats.log property.

      1. disable-logging.diff
        2 kB
        Knut Anders Hatlen

        Issue Links

          Activity

          Knut Anders Hatlen added a comment -

          If we disable logging by default, we need to update the release note attached to DERBY-4939 to reflect that.

          Knut Anders Hatlen added a comment -

          Attaching a patch that makes logging disabled by default. According to the comments in the code, the logging was intended to be disabled before the release.

          Running regression tests.

          Knut Anders Hatlen added a comment -

          The regression tests ran cleanly with the patch.

          Knut Anders Hatlen added a comment -

          Committed revision 1076559.


            People

            • Assignee:
              Knut Anders Hatlen
              Reporter:
              Knut Anders Hatlen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development