Derby
  1. Derby
  2. DERBY-5032

[patch] derived InternalXact attempts (and fails) to override a method from base

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 10.7.1.1
    • Fix Version/s: 10.8.1.2
    • Component/s: Network Server
    • Labels:
      None
    • Urgency:
      Normal
    • Bug behavior facts:
      Regression

      Description

      RawTransaction implements

      public void checkLogicalOperationOk() throws StandardException {
      }

      which is attempted to be overridden in derived class InternalXact, but is not done so because of a case problem in InternalXact
      public void checkLogicalOperationOK()
      throws StandardException

      { throw StandardException.newException( SQLState.XACT_NOT_SUPPORTED_IN_INTERNAL_XACT); }

      Code that calls this method thru the parent will not get the overridden method called.

        Activity

        Knut Anders Hatlen added a comment -

        Thanks, Dave! Regression tests passed with the patch.

        Committed revision 1071314.


          People

          • Assignee:
            Dave Brosius
            Reporter:
            Dave Brosius
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1h
              1h
              Remaining:
              Remaining Estimate - 1h
              1h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development