Derby
  1. Derby
  2. DERBY-5028

InterruptResilienceTest passes with IBM 1.6 SR9 but creates javacore dumps

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.8.1.2
    • Fix Version/s: 10.8.1.2
    • Component/s: Test
    • Labels:
      None
    • Environment:
      windows xp, IBM java 1.6 SR9
    • Bug behavior facts:
      Regression Test Failure

      Description

      After DERBY-4463, it was found there was a bug with the IBM jvms in the handling of interrupt() and waitFor().
      This is fixed with IBM 1.6 SR9 (and is planned for IBM 1.5 SR13).
      As SR9 is now GA, I thought to adjust the skipping of this test to only with ibm 1.5.
      However, I now notice that the test drops java core dumps with ibm 1.6 SR6. It does not do this with Sun's 1.6 jvm.
      I also believe that it didn't do this a couple of weeks ago when I first tried this with ibm 1.6 SR9, so I think something has changed in derby, but it is possible I was not paying proper attention.

        Activity

        Myrna van Lunteren added a comment -

        attaching a patch/diff which adjusts the skipping of the test for DERBY-4463 to be only done with ibm 1.5.
        Needed to see the javacores with ibm 1.6.

        Myrna van Lunteren added a comment -

        sync-ed trunk up to revision 1069908 to see this.
        What I can find of saved directories shows that I ran this when there was only test fixture testIRT - at that time the that test left no javacores behind - so probably before revision 1064174.

        Knut Anders Hatlen added a comment -

        Perhaps you see the javacore files because of DERBY-4856? Since the interrupts cause session severity errors, I think that code will kick in and generate thread dumps. Also, I think only support for IBM was implemented, which would explain why you don't see the files with Sun.

        Myrna van Lunteren added a comment -

        That makes sense...
        These files tend to be largish. If they're expected in this test, I don't think they need to stay around...I'll see if there's a way to add deleting them to the cleanup.

        Lily Wei added a comment -

        There are two way to avoid the problem: deleting them to the cleanup or set the derby.stream.error.extendedDiagSeverityLevel higher so javacore file does not get created.

        Myrna van Lunteren added a comment -

        Thanks Lily! I added the setting of the property to the already existing SystemPropertySetup settings, and now no javacore files show up. Committed with revision 1071545.


          People

          • Assignee:
            Myrna van Lunteren
            Reporter:
            Myrna van Lunteren
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development