Derby
  1. Derby
  2. DERBY-4912

Instability in Derby2017LayerBTest

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.6.2.1, 10.7.1.1, 10.8.1.2
    • Fix Version/s: 10.6.2.2, 10.7.1.4, 10.8.1.2
    • Component/s: Test
    • Labels:
      None
    • Bug behavior facts:
      Regression Test Failure

      Description

      Seen on 10.7 RC1:

      testFailedStreamInsertBinaryAutoCommitRollbackOnError(org.apache.derbyTesting.functionTests.tests.jdbc4.Derby2017LayerBTest) FAILURE:
      junit.framework.AssertionFailedError: Column value mismatch @ column 'B', row 1:
      Expected: >5468697320697320726f772031<
      Found: >5468697320697320726f772036<
      at junit.framework.Assert.fail(Assert.java:47)
      at org.apache.derbyTesting.junit.JDBC.assertRowInResultSet(JDBC.java:1213)
      at org.apache.derbyTesting.junit.JDBC.assertRowInResultSet(JDBC.java:1125)
      at org.apache.derbyTesting.junit.JDBC.assertFullResultSetMinion(JDBC.java:1012)
      at org.apache.derbyTesting.junit.JDBC.assertFullResultSet(JDBC.java:935)
      at org.apache.derbyTesting.junit.JDBC.assertFullResultSet(JDBC.java:892)
      at org.apache.derbyTesting.junit.JDBC.assertFullResultSet(JDBC.java:850)
      at org.apache.derbyTesting.functionTests.tests.jdbc4.Derby2017LayerBTest.doInsertTest(Derby2017LayerBTest.java:493)
      at org.apache.derbyTesting.functionTests.tests.jdbc4.Derby2017LayerBTest.testFailedStreamInsertBinaryAutoCommitRollbackOnError(Derby2017LayerBTest.java:315)

        Activity

        Kristian Waagan added a comment -

        Backported patch 1a to 10.7 with revision 1042685, and to 10.6 with revision 1042686.

        I don't expect any more work on this issue.

        Dag H. Wanvik added a comment -

        Kristian, I did not see the error when I ran the test stand-alone. I saw it when running
        the tests in parallel using Knut's script, with 6 threads. Thanks for picking this one up!

        Kristian Waagan added a comment -

        Updated affects versions. This instability is also present in 10.6.

        Kristian Waagan added a comment -

        Attached patch 1a, which makes the result set assert ignore the order of the rows.
        Committed to trunk with revision 1038514. Will backport tomorrow.

        This is another case where it would have been interesting to understand why Dag is the only one (so far) seeing a different ordering of the result. Labeled as instability, I assume he's not even seeing it consistently.

        Dag, did this test ever fail when run standalone, or did you only see the problem when running suites.All?
        (the latter may point towards memory related issues affecting the order)

        Dag H. Wanvik added a comment -

        Running it standalone I saw no error, so it seems to be another result set ordering Heisenbug.


          People

          • Assignee:
            Kristian Waagan
            Reporter:
            Dag H. Wanvik
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development