Derby
  1. Derby
  2. DERBY-4763

The entity   isn't one of XML's predefined entities, if you want to use it in an XML document then you have to provide a DTD that declares what it means or use  

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not a Problem
    • Affects Version/s: 10.6.1.0
    • Fix Version/s: None
    • Component/s: Documentation
    • Urgency:
      Low
    • Issue & fix info:
      Known fix, Newcomer
    • Bug behavior facts:
      Deviation from standard

      Description

      Not sure if this is an issue, and I note that nbsp is used in the following files as well. But I get the following warnings when doing a " ant pdf.getstart " and following the instructions at http://db.apache.org/derby/manuals/dita.html. Though I have got the latest Dita toolkit

      [pipeline] tgsrunningdblook.dita Line 23:The entity "nbsp" was referenced, but not declared.
      [pipeline] cwwdactivities.dita Line 33:The entity "nbsp" was referenced, but not declared.
      [pipeline] twwdactivity1.dita Line 23:The entity "nbsp" was referenced, but not declared.
      [pipeline] tgsrunningij.dita Line 23:The entity "nbsp" was referenced, but not declared.
      [pipeline] twwdactivity1_Setup.dita Line 68:The entity "nbsp" was referenced, but not declared.
      [pipeline] tgssetupverify.dita Line 52:The entity "nbsp" was referenced, but not declared.

      I altered it in tgsrunningsysinfo.dita to what I think it should be.

      — src/getstart/tgsrunningsysinfo.dita (revision 983219)
      +++ src/getstart/tgsrunningsysinfo.dita (working copy)
      @@ -20,7 +20,7 @@
      -->
      <task id="tgsrunningsysinfo" xml:lang="en-us">
      <title>Running sysinfo</title>
      -<shortdesc>The <ph conref="../conrefs.dita#prod/productshortname"></ph> <codeph>sysinfo</codeph> tool
      +<shortdesc>The <ph conref="../conrefs.dita#prod/productshortname"></ph> <codeph>sysinfo</codeph> tool
      displays information about your Java environment and your version of <ph conref="../conrefs.dita#prod/productshortname"></ph>.</shortdesc>
      <prolog><metadata>
      <keywords><indexterm><indexterm>Derby</indexterm>tools, sysinfo</indexterm>

        Activity

        Kim Haase added a comment -

        Thanks for pointing this out. We have been recommending the use of a very old version of the DITA toolkit (1.1.2.1), and it does not seem to generate this warning, although it generates many others. If you are using the latest version and are successfully producing output, we're very interested in hearing about it. In past years we had problems with more recent versions, and no one has found the time to test a new Toolkit version in a while.

        There have in the past been some problems generating correct output with   if the user's LANG environment variable was not set quite right. (See DERBY-4547 for some history on this.) This is no longer a major issue, since we tell people how to set the variable on the http://db.apache.org/derby/manuals/dita.html page. This may be the time to switch from   to   if someone has the time to make this fix to the documentation.

        Nigel Owen added a comment - - edited

        I was looking at this to get a better understanding of DITA, I learn better when I am trying to fix a problem so I will look at porting this to the latest toolkit, it should be pretty simple, there is just an issue with table links I think but it does build.

        Will let you know when I have it working completely under the latest toolkit (you can let me know if you still want it then) this may be awhile as work lately is pretty busy.

        And my LANG variable is fine

        $ echo $LANG
        en_US.UTF-8

        and on a linux system I just ran the command below on the src directory to search and replace and it seems to build fine, though the output pdf files are missing the address links.

        find . -name *.dita -exec sed -i -e 's/ /\&#160\;/g' {} \;

        Kim Haase added a comment -

        Thanks for testing the docs with the latest toolkit! Let us know if you run into any other incompatibilities.

        Table links have been an issue for some time – if the new toolkit doesn't solve that problem, it's not a regression.

        I'm not sure what you mean by "address links"?

        Kim Haase added a comment -

        It could also be mentioned that the file DITA-OT1.1.2.1/dtd/topic.mod defines nbsp as an entity:

        <!ENTITY nbsp " " >

        So do several of the XSL files that we use. So we do not see errors when we build the docs.

        Mamta A. Satoor added a comment -

        There hasn't been any activity on this issue for over 2 years now. I wonder if we have moved to the new toolkit and if this is not an issue anymore?

        Kim Haase added a comment -

        We have not been able to move to a new toolkit, but because we declare the entity "nbsp" in some of our XSL files, we do not get this warning.


          People

          • Assignee:
            Unassigned
            Reporter:
            Nigel Owen
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 5m
              5m
              Remaining:
              Remaining Estimate - 5m
              5m
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development