Uploaded image for project: 'Derby'
  1. Derby
  2. DERBY-4761

javadoc warnings for 10.3 with jdk 1.6 set

Agile BoardAttach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 10.3.3.0
    • 10.2.2.1, 10.3.3.1
    • Build tools
    • None
    • with sun jdk 1.6 u21 b7
    • Regression

    Description

      I tried to upgrade from an ancient version of the sun jdk to 1.6 u21 b7, but now my javadoc build for 10.3 (10.3.3.1) has a number of errors re 'generics' usage:

      java\engine\org\apache\derby\iapi\jdbc\BrokeredCallableStatement40.java:303: generics are

      not supported in -source 1.4
      [javadoc] (use -source 5 or higher to enable generics)
      [javadoc] public <T> T unwrap(java.lang.Class<T> interfaces)
      [javadoc] ^

      etc.

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            myrna Myrna van Lunteren
            myrna Myrna van Lunteren
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment