Derby
  1. Derby
  2. DERBY-4546

test_13_sqlData(org.apache.derbyTesting.functionTests.tests.lang.UDTTest) fails on weme 6.2 with java.sql.SQLException: The class 'org.apache.derbyTesting.functionTests.tests.lang.SampleSQLData' for column 'DATA' does not exist or is inaccessible.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.6.1.0
    • Fix Version/s: 10.6.1.0
    • Component/s: JDBC
    • Labels:
      None
    • Environment:
      IBM weme6.2
      Windows XP - x86 - 5.1 build 2600 Service Pack 3
    • Bug behavior facts:
      Regression Test Failure

      Description

      Starting Monday, Feb 8 with svn 907888,
      test_13_sqlData started failing as below.

      It appears to be in the JDBC prepareStatement call so may be an actual code bug and not a test issue, but I am not sure.

      http://people.apache.org/~myrnavl/derby_test_results/main/windows/testlog/weme6.2/907888-suites.All_diff.txt

      2) test_13_sqlData(org.apache.derbyTesting.functionTests.tests.lang.UDTTest)java.sql.SQLException: The class
      'org.apache.derbyTesting.functionTests.tests.lang.SampleSQLData' for column 'DATA' does not exist or is inaccessible. This can happen if the class is not public.
      at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.seeNextException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.ConnectionChild.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedPreparedStatement.<init>(Unknown Source)
      at org.apache.derby.jdbc.Driver169.newEmbedPreparedStatement(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.prepareStatement(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.prepareStatement(Unknown Source)
      at org.apache.derbyTesting.functionTests.tests.lang.GeneratedColumnsHelper.chattyPrepare(GeneratedColumnsHelper.java:157)
      at org.apache.derbyTesting.functionTests.tests.lang.GeneratedColumnsHelper.goodStatement(GeneratedColumnsHelper.java:135)
      at org.apache.derbyTesting.functionTests.tests.lang.UDTTest.test_13_sqlData(UDTTest.java:919)
      at java.lang.reflect.AccessibleObject.invokeV(AccessibleObject.java:195)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:109)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      Caused by: java.sql.SQLException: Java exception: 'org.apache.derbyTesting.functionTests.tests.lang.SampleSQLData : java.sql.SQLData: java.lang.ClassNotFoundException'.
      at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.javaException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unknown Source)
      ... 43 more
      Caused by: java.lang.ClassNotFoundException: org.apache.derbyTesting.functionTests.tests.lang.SampleSQLData : java.sql.SQLData
      at java.lang.Throwable.<init>(Throwable.java:80)
      at java.lang.ClassNotFoundException.<init>(ClassNotFoundException.java:44)
      at org.apache.derby.impl.services.reflect.DatabaseClasses.loadApplicationClass(Unknown Source)
      at org.apache.derby.iapi.services.loader.ClassInspector.getClass(Unknown Source)
      at org.apache.derby.iapi.services.loader.ClassInspector.accessible(Unknown Source)
      at org.apache.derby.impl.sql.compile.ColumnDefinitionNode.checkUserType(Unknown Source)
      at org.apache.derby.impl.sql.compile.TableElementList.validate(Unknown Source)
      at org.apache.derby.impl.sql.compile.CreateTableNode.bindStatement(Unknown Source)
      at org.apache.derby.impl.sql.GenericStatement.prepMinion(Unknown Source)
      at org.apache.derby.impl.sql.GenericStatement.prepare(Unknown Source)
      at org.apache.derby.impl.sql.conn.GenericLanguageConnectionContext.prepareInternalStatement(Unknown Source)
      ... 39 more

        Activity

        Rick Hillegas added a comment -

        Should be fixed by the fix to DERBY-4545.

        Myrna van Lunteren added a comment -

          People

          • Assignee:
            Rick Hillegas
            Reporter:
            Kathey Marsden
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development