Derby
  1. Derby
  2. DERBY-4300

testResultSetGarbageCollection failed with 10.3 server 10.5 client testing with connection has been terminiated

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 10.5.1.1
    • Fix Version/s: None
    • Component/s: Network Server
    • Labels:
      None
    • Environment:
      Window vista.
    • Urgency:
      Urgent
    • Issue & fix info:
      Newcomer
    • Bug behavior facts:
      Regression

      Description

      testResultSetGarbageCollection(org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoGenJDBC30Test)java.sql.SQLException: Insufficient data while reading from the network - expected a minimum of 6 bytes and received only 0 bytes. The connection has been terminated. It looks like the server was not available for the other fixtures after this occurs with: A communications error has been detected: Connection reset. message.

      This the trace dump:
      1) testResultSetGarbageCollection(org.apache.derbyTesting.functionTests.tests.jd
      bcapi.AutoGenJDBC30Test)java.sql.SQLException: Insufficient data while reading f
      rom the network - expected a minimum of 6 bytes and received only 0 bytes. The
      connection has been terminated.
      at org.apache.derby.client.am.SQLExceptionFactory.getSQLException(SQLExc
      eptionFactory.java:46)
      at org.apache.derby.client.am.SqlException.getSQLException(SqlException.
      java:358)
      at org.apache.derby.client.am.PreparedStatement.executeUpdate(PreparedSt
      atement.java:399)
      at org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoGenJDBC30Test
      .testResultSetGarbageCollection(AutoGenJDBC30Test.java:933)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:
      89)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57
      )
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57
      )
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      Caused by: org.apache.derby.client.am.DisconnectException: Insufficient data whi
      le reading from the network - expected a minimum of 6 bytes and received only 0
      bytes. The connection has been terminated.
      at org.apache.derby.client.net.Reply.fill(Reply.java:198)
      at org.apache.derby.client.net.Reply.ensureALayerDataInBuffer(Reply.java
      :218)
      at org.apache.derby.client.net.Reply.readDssHeader(Reply.java:320)
      at org.apache.derby.client.net.Reply.startSameIdChainParse(Reply.java:11
      60)
      at org.apache.derby.client.net.NetStatementReply.readExecute(NetStatemen
      tReply.java:70)
      at org.apache.derby.client.net.StatementReply.readExecute(StatementReply
      .java:55)
      at org.apache.derby.client.net.NetPreparedStatement.readExecute_(NetPrep
      aredStatement.java:189)
      at org.apache.derby.client.am.PreparedStatement.readExecute(PreparedStat
      ement.java:1811)
      at org.apache.derby.client.am.PreparedStatement.flowExecute(PreparedStat
      ement.java:2108)
      at org.apache.derby.client.am.PreparedStatement.executeUpdateX(PreparedS
      tatement.java:404)
      at org.apache.derby.client.am.PreparedStatement.executeUpdate(PreparedSt
      atement.java:390)
      ... 41 more

      I run the test by itself using 'java junit.textui.TestRunner org.apache.derbyTesting.functionTests.tests.jdbc
      api.AutoGenJDBC30Test'. The failure did not occur in that case.

      1. Derby-4300.diff
        7 kB
        Lily Wei
      2. test10520.zip
        1.01 MB
        Lily Wei

        Activity

        Kathey Marsden added a comment -

        Hi Lily, I committed the patch to backport derby.tests.trace to 10.3. I am resolving this Cannot Reproduce since you could not get it to happen again.,

        Lily Wei added a comment -

        The is the output, log file and database for mailjdbc after running 1 full day of mailjdbc for embedded server with 10.5.2.0 lib-debug version with Sun 1.6 JDK.

        Lily Wei added a comment -

        Attach backport for junit\BaseTestCase.java and junit\TestConfiguration.java so it will print out test name as we run test on 10.3

        Lily Wei added a comment -

        I try to reproduce the same failure for testResultSetGarbageCollection. I can not reproduce any more. This is after rerun suites.all with 10.3 server and 10.5 client.

        Lily Wei added a comment -

        I was able to reproduce this bug by running jdbcapi._Suite.
        1) testGetBinaryStream(org.apache.derbyTesting.functionTests.tests.jdbcapi.Large
        DataLocksTest)junit.framework.AssertionFailedError: expected:<0> but was:<2>
        at org.apache.derbyTesting.functionTests.tests.jdbcapi.LargeDataLocksTes
        t.testGetBinaryStream(LargeDataLocksTest.java:114)


          People

          • Assignee:
            Unassigned
            Reporter:
            Lily Wei
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development