Derby
  1. Derby
  2. DERBY-4167

NullPointerException in StressMultiTest (testStressMulti) with ibm 1.5 on iseries

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 10.5.1.1
    • Fix Version/s: None
    • Component/s: Test
    • Labels:
      None
    • Environment:
      IBM iseries, OS: AS/400; OS version: V5R4M0, jvm: IBM 1.5 (build 1.5.0_13-b05)
    • Bug behavior facts:
      Regression Test Failure

      Description

      suites.All on iseries with 10.5 rc2 stumbled with this stack trace:

      1) testStressMulti(org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest)junit.framework.AssertionFailedError: Caused by:
      java.sql.SQLException: Java exception: ': java.lang.NullPointerException'.
      at java.lang.Throwable.<init>(Throwable.java:196)
      at java.lang.Exception.<init>(Exception.java:41)
      at java.sql.SQLException.<init>(SQLException.java:40)
      at org.apache.derby.impl.jdbc.EmbedSQLException.<init>(Unknown Source)
      at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.javaException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.ConnectionChild.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedStatement.executeStatement(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedStatement.execute(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedStatement.execute(Unknown Source)
      at org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest$StressMultiRunnable.create(StressMultiTest.java:446)
      at org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest$StressMultiRunnable.run(StressMultiTest.java:372)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: java.lang.NullPointerException
      at org.apache.derby.impl.store.raw.data.BaseDataFileFactory.openContainer(Unknown Source)
      at org.apache.derby.impl.store.raw.data.BaseDataFileFactory.openContainer(Unknown Source)
      at org.apache.derby.impl.store.raw.xact.Xact.openContainer(Unknown Source)
      at org.apache.derby.impl.store.access.conglomerate.OpenConglomerate.init(Unknown Source)
      at org.apache.derby.impl.store.access.heap.Heap.open(Unknown Source)
      at org.apache.derby.impl.store.access.RAMTransaction.openConglomerate(Unknown Source)
      at org.apache.derby.impl.store.access.RAMTransaction.openCompiledConglomerate(Unknown Source)
      at org.apache.derby.impl.sql.execute.RowChangerImpl.openForUpdate(Unknown Source)
      at org.apache.derby.impl.sql.execute.RowChangerImpl.open(Unknown Source)
      at org.apache.derby.impl.sql.execute.RowChangerImpl.open(Unknown Source)
      at org.apache.derby.impl.sql.execute.InsertResultSet.normalInsertCore(Unknown Source)
      at org.apache.derby.impl.sql.execute.InsertResultSet.open(Unknown Source)
      at org.apache.derby.impl.sql.GenericPreparedStatement.executeStmt(Unknown Source)
      at org.apache.derby.impl.sql.GenericPreparedStatement.execute(Unknown Source)
      ... 6 more

      at java.lang.Throwable.<init>(Throwable.java:196)
      at java.lang.Error.<init>(Error.java:49)
      at junit.framework.AssertionFailedError.<init>(AssertionFailedError.java:11)
      at org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest.handleException(StressMultiTest.java:331)
      at org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest.access$200(StressMultiTest.java:70)
      at org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest$StressMultiRunnable.run(StressMultiTest.java:372)
      at java.lang.Thread.run(Thread.java:595)

      I think this subsequently caused the following failures:
      38) org.apache.derbyTesting.functionTests.tests.multi.StressMultiTestjava.sql.SQLException: Failed to start database 'singleUse/oneuse4d', see the next exception for details.
      at java.lang.Throwable.<init>(Throwable.java:196)
      at java.lang.Exception.<init>(Exception.java:41)
      at java.sql.SQLException.<init>(SQLException.java:40)
      at org.apache.derby.impl.jdbc.EmbedSQLException.<init>(Unknown Source)
      at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.seeNextException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.bootDatabase(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.<init>(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection30.<init>(Unknown Source)
      at org.apache.derby.jdbc.Driver30.getNewEmbedConnection(Unknown Source)
      at org.apache.derby.jdbc.InternalDriver.connect(Unknown Source)
      at org.apache.derby.jdbc.AutoloadedDriver.connect(Unknown Source)
      at java.sql.DriverManager.getConnection(DriverManager.java:525)
      at java.sql.DriverManager.getConnection(DriverManager.java:171)
      at org.apache.derbyTesting.junit.DriverManagerConnector.openConnection(DriverManagerConnector.java:67)
      at org.apache.derbyTesting.junit.DriverManagerConnector.openConnection(DriverManagerConnector.java:43)
      at org.apache.derbyTesting.junit.TestConfiguration.openDefaultConnection(TestConfiguration.java:1314)
      at org.apache.derbyTesting.junit.BaseJDBCTestSetup.getConnection(BaseJDBCTestSetup.java:72)
      at org.apache.derbyTesting.junit.CleanDatabaseTestSetup.tearDown(CleanDatabaseTestSetup.java:140)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:20)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      Caused by: java.sql.SQLException: Startup failed. An encrypted database cannot be accessed without the correct boot password.
      at java.lang.Throwable.<init>(Throwable.java:196)
      at java.lang.Exception.<init>(Exception.java:41)
      at java.sql.SQLException.<init>(SQLException.java:40)
      at org.apache.derby.impl.jdbc.EmbedSQLException.<init>(Unknown Source)
      at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.generateCsSQLException(Unknown Source)
      ... 45 more
      Caused by: ERROR XBM06: Startup failed. An encrypted database cannot be accessed without the correct boot password.
      at java.lang.Throwable.<init>(Throwable.java:196)
      at java.lang.Exception.<init>(Exception.java:41)
      at org.apache.derby.iapi.error.StandardException.<init>(Unknown Source)
      at org.apache.derby.iapi.error.StandardException.<init>(Unknown Source)
      at org.apache.derby.iapi.error.StandardException.newException(Unknown Source)
      at org.apache.derby.impl.services.jce.JCECipherFactory.handleBootPassword(Unknown Source)
      at org.apache.derby.impl.services.jce.JCECipherFactory.init(Unknown Source)
      at org.apache.derby.impl.services.jce.JCECipherFactory.<init>(Unknown Source)
      at org.apache.derby.impl.services.jce.JCECipherFactoryBuilder.createCipherFactory(Unknown Source)
      at org.apache.derby.impl.store.raw.RawStore.setupEncryptionEngines(Unknown Source)
      at org.apache.derby.impl.store.raw.RawStore.boot(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.boot(Unknown Source)
      at org.apache.derby.impl.services.monitor.TopService.bootModule(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.startModule(Unknown Source)
      at org.apache.derby.iapi.services.monitor.Monitor.bootServiceModule(Unknown Source)
      at org.apache.derby.impl.store.access.RAMAccessManager.boot(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.boot(Unknown Source)
      at org.apache.derby.impl.services.monitor.TopService.bootModule(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.startModule(Unknown Source)
      at org.apache.derby.iapi.services.monitor.Monitor.bootServiceModule(Unknown Source)
      at org.apache.derby.impl.db.BasicDatabase.bootStore(Unknown Source)
      at org.apache.derby.impl.db.BasicDatabase.boot(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.boot(Unknown Source)
      at org.apache.derby.impl.services.monitor.TopService.bootModule(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.bootService(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.startProviderService(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.findProviderAndStartService(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.startPersistentService(Unknown Source)
      at org.apache.derby.iapi.services.monitor.Monitor.startPersistentService(Unknown Source)
      ... 45 more
      39) org.apache.derbyTesting.functionTests.tests.multi.StressMultiTestjava.sql.SQLException: Failed to start database 'singleUse/oneuse4d', see the next exception for details.
      at java.lang.Throwable.<init>(Throwable.java:196)
      at java.lang.Exception.<init>(Exception.java:41)
      at java.sql.SQLException.<init>(SQLException.java:40)
      at org.apache.derby.impl.jdbc.EmbedSQLException.<init>(Unknown Source)
      at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.seeNextException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.bootDatabase(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.<init>(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection30.<init>(Unknown Source)
      at org.apache.derby.jdbc.Driver30.getNewEmbedConnection(Unknown Source)
      at org.apache.derby.jdbc.InternalDriver.connect(Unknown Source)
      at org.apache.derby.jdbc.AutoloadedDriver.connect(Unknown Source)
      at java.sql.DriverManager.getConnection(DriverManager.java:525)
      at java.sql.DriverManager.getConnection(DriverManager.java:171)
      at org.apache.derbyTesting.junit.DriverManagerConnector.openConnection(DriverManagerConnector.java:67)
      at org.apache.derbyTesting.junit.DriverManagerConnector.openConnection(DriverManagerConnector.java:43)
      at org.apache.derbyTesting.junit.TestConfiguration.openDefaultConnection(TestConfiguration.java:1314)
      at org.apache.derbyTesting.junit.BaseJDBCTestSetup.getConnection(BaseJDBCTestSetup.java:72)
      at org.apache.derbyTesting.junit.DatabasePropertyTestSetup.tearDown(DatabasePropertyTestSetup.java:280)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:20)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      Caused by: java.sql.SQLException: Startup failed. An encrypted database cannot be accessed without the correct boot password.
      at java.lang.Throwable.<init>(Throwable.java:196)
      at java.lang.Exception.<init>(Exception.java:41)
      at java.sql.SQLException.<init>(SQLException.java:40)
      at org.apache.derby.impl.jdbc.EmbedSQLException.<init>(Unknown Source)
      at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.generateCsSQLException(Unknown Source)
      ... 40 more
      Caused by: ERROR XBM06: Startup failed. An encrypted database cannot be accessed without the correct boot password.
      at java.lang.Throwable.<init>(Throwable.java:196)
      at java.lang.Exception.<init>(Exception.java:41)
      at org.apache.derby.iapi.error.StandardException.<init>(Unknown Source)
      at org.apache.derby.iapi.error.StandardException.<init>(Unknown Source)
      at org.apache.derby.iapi.error.StandardException.newException(Unknown Source)
      at org.apache.derby.impl.services.jce.JCECipherFactory.handleBootPassword(Unknown Source)
      at org.apache.derby.impl.services.jce.JCECipherFactory.init(Unknown Source)
      at org.apache.derby.impl.services.jce.JCECipherFactory.<init>(Unknown Source)
      at org.apache.derby.impl.services.jce.JCECipherFactoryBuilder.createCipherFactory(Unknown Source)
      at org.apache.derby.impl.store.raw.RawStore.setupEncryptionEngines(Unknown Source)
      at org.apache.derby.impl.store.raw.RawStore.boot(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.boot(Unknown Source)
      at org.apache.derby.impl.services.monitor.TopService.bootModule(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.startModule(Unknown Source)
      at org.apache.derby.iapi.services.monitor.Monitor.bootServiceModule(Unknown Source)
      at org.apache.derby.impl.store.access.RAMAccessManager.boot(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.boot(Unknown Source)
      at org.apache.derby.impl.services.monitor.TopService.bootModule(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.startModule(Unknown Source)
      at org.apache.derby.iapi.services.monitor.Monitor.bootServiceModule(Unknown Source)
      at org.apache.derby.impl.db.BasicDatabase.bootStore(Unknown Source)
      at org.apache.derby.impl.db.BasicDatabase.boot(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.boot(Unknown Source)
      at org.apache.derby.impl.services.monitor.TopService.bootModule(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.bootService(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.startProviderService(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.findProviderAndStartService(Unknown Source)
      at org.apache.derby.impl.services.monitor.BaseMonitor.startPersistentService(Unknown Source)
      at org.apache.derby.iapi.services.monitor.Monitor.startPersistentService(Unknown Source)
      ... 40 more

      1. error-stacktrace.out
        2 kB
        Mamta A. Satoor
      2. derby.log
        2.14 MB
        Mamta A. Satoor

        Activity

        Knut Anders Hatlen added a comment -

        Just thought I'd point out that we have other reports of NPE in BaseFileFactory.openContainer() that may or may not be related to this bug:

        DERBY-3524
        DERBY-3746
        DERBY-3976 (closed as invalid, but it might still indicate a cause - too many open files - in which case an error stating that should be found in the derby.log that was copied to the fail directory)

        Myrna van Lunteren added a comment -

        Thanks for finding those other issues.
        There was nothing saved in the fail directory for the multi test. No derby.log files as saved have anything re the too many open files...So, unless I can duplicate it, this remains a mystery.

        Mamta A. Satoor added a comment -

        Saw NPE for testStressMulti on trunk(10.7 revision 956758) on a windows machine with ibm15. The stack trace looks as follows
        1) testStressMulti(org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest)junit.framework.AssertionFailedError: Caused by:
        java.sql.SQLException: Java exception: ': java.lang.NullPointerException'.
        at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
        at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
        at org.apache.derby.impl.jdbc.Util.javaException(Unknown Source)
        at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unknown Source)
        at org.apache.derby.impl.jdbc.TransactionResourceImpl.handleException(Unknown Source)
        at org.apache.derby.impl.jdbc.EmbedConnection.handleException(Unknown Source)
        at org.apache.derby.impl.jdbc.ConnectionChild.handleException(Unknown Source)
        at org.apache.derby.impl.jdbc.EmbedStatement.execute(Unknown Source)
        at org.apache.derby.impl.jdbc.EmbedStatement.executeQuery(Unknown Source)
        at org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest$StressMultiRunnable.select(StressMultiTest.java:555)
        at org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest$StressMultiRunnable.run(StressMultiTest.java:429)
        at java.lang.Thread.run(Thread.java:811)
        Caused by: java.lang.NullPointerException
        at org.apache.derby.impl.sql.GenericActivationHolder.<init>(Unknown Source)
        at org.apache.derby.impl.sql.GenericPreparedStatement.getActivation(Unknown Source)
        ... 5 more

        at org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest.handleException(StressMultiTest.java:351)
        at org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest.access$200(StressMultiTest.java:70)
        at org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest$StressMultiRunnable.run(StressMultiTest.java:445)
        at java.lang.Thread.run(Thread.java:811)

        Mamta A. Satoor added a comment -

        Attaching derby.log from the failure on windows machine

        Knut Anders Hatlen added a comment -

        Hi Mamta,

        This looks like a different bug. The NPE Myrna saw was in store, whereas the one you saw was in the language layer. If I were to guess, this latter NPE may be related to the recently committed fix for DERBY-4279, since it seems to have caused some other NPEs in StressMultiTest in the Tinderbox lately. I'd suggest that you file a separate bug report for the issue you're seeing. Thanks.

        Mamta A. Satoor added a comment -

        Thanks, Knut. I created a new jira DERBY-4721 and made a reference to DERBY-4279 in it.

        Myrna van Lunteren added a comment -

        Haven't seen this for 10.6, nor 10.7 cycles. Will reopen if I see it again.


          People

          • Assignee:
            Unassigned
            Reporter:
            Myrna van Lunteren
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development