Uploaded image for project: 'Derby'
  1. Derby
  2. DERBY-4147

DerbyServer shutdown unexpected after running for some days

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 10.4.2.0
    • Fix Version/s: None
    • Component/s: Network Server
    • Environment:
      Windows XP Pro,
      java version "1.5.0_07"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_07-b03)
      Java HotSpot(TM) Client VM (build 1.5.0_07-b03, mixed mode, sharing)
    • Urgency:
      Normal
    • Bug behavior facts:
      Crash, Seen in production

      Description

      My derby network server was fine, but recently it becoming unstable and it shudown itself by exception.

      ------
      Apache Derby Network Server - 10.4.2.0 - (689064) started and ready to accept co
      nnections on port 1527 at 2009-04-02 01:41:10.147 GMT
      null
      java.lang.NullPointerException
      at org.apache.derby.impl.drda.DRDAStatement.execute(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.parseEXCSQLSTTobjects(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.parseEXCSQLSTT(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.processCommands(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.run(Unknown Source)
      Execution failed because of Permanent Agent Error: SVRCOD = 40; RDBNAM = schedul
      er; diagnostic msg = null
      org.apache.derby.impl.drda.DRDAProtocolException: Execution failed because of Pe
      rmanent Agent Error: SVRCOD = 40; RDBNAM = scheduler; diagnostic msg = null
      at org.apache.derby.impl.drda.DRDAProtocolException.newAgentError(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.sendUnexpectedException(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.handleException(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.run(Unknown Source)
      null
      java.lang.NullPointerException
      at org.apache.derby.impl.drda.DRDAStatement.execute(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.parseEXCSQLSTTobjects(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.parseEXCSQLSTT(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.processCommands(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.run(Unknown Source)
      Apache Derby Network Server - 10.4.2.0 - (689064) shutdown at 2009-04-05 23:10:07.938 GMT

        Activity

        knutanders Knut Anders Hatlen added a comment -

        Does derby.log show any errors just before the server went down?
        Do you know what kind of statement was being executed when the server crashed?

        hkdennis2k Dennis Cheung added a comment -

        It was down again and I checked the log file.

        derby.log does not contain any error message.

        I don't know what was being execeuted as there are many running progress.

        myrna Myrna van Lunteren added a comment -

        If this is still occurring regularly, it may be a good idea to increase the information going to derby.log.

        You do this by creating, or adding to, a file called derby.properties in the dir where the server gets started
        Suggested properties are:
        derby.infolog.append=true
        derby.stream.error.logSeverityLevel=0
        derby.language.logStatementText=true

        (you can find more about what these properties do in the manuals)

        HTH

        rhillegas Rick Hillegas added a comment -

        Triaged July 2, 2009: Assigning normal urgency.

        rhillegas Rick Hillegas added a comment -

        Closing this issue as "Cannot Reproduce" because there is not enough information to pursue the problem--almost a year has elapsed since the last substantive posting on this issue. The issue can be re-opened if more information becomes available.


          People

          • Assignee:
            Unassigned
            Reporter:
            hkdennis2k Dennis Cheung
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development