Derby
  1. Derby
  2. DERBY-4118

ComparisonFailure in 'testSysinfo(org.apache.derbyTesting.functionTests.tests.derbynet.SysinfoTest)' on Derby 10.5 / Linux

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 10.5.2.0, 10.6.1.0
    • Component/s: Test
    • Labels:
      None
    • Environment:
    • Bug behavior facts:
      Regression Test Failure

      Description

      See e.g.

      http://dbtg.thresher.com/derby/test/10.5Branch/jvm1.6/testing/testlog/lin/757918-suitesAll_diff.txt

      1) testSysinfo(org.apache.derbyTesting.functionTests.tests.derbynet.SysinfoTest)junit.framework.ComparisonFailure: expected:<...nformation --------
      []--------------------...> but was:<...nformation --------
      [Unable to analyze class path: access denied (java.util.PropertyPermission java.class.path read)
      ]--------------------...>
      at org.apache.derbyTesting.functionTests.tests.derbynet.SysinfoTest.testSysinfo(SysinfoTest.java:214)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:105)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)

      1. permission.diff
        0.8 kB
        Knut Anders Hatlen

        Activity

        Knut Anders Hatlen added a comment -

        Committed to trunk with revision 765955.
        Committed to 10.5 with revision 765956.

        Knut Anders Hatlen added a comment -

        Kathey's guess was close, but SysinfoTest has its own policy file, so the extra permission must go into SysinfoTest.policy instead of derby_tests.policy. See attached patch.

        Kathey Marsden added a comment -

        I think derbyclient.jar needs permission
        permission java.util.PropertyPermission "java.class.path", "read";
        in derby_tests.policy.

        Ole Solberg added a comment -

        I was able to reproduce this behaviour also on trunk:

        The following classpath was ok:
        CLASSPATH=derby.jar:derbyclient.jar:derbytools.jar:derbynet.jar:........

        while this one failed the same way:
        CLASSPATH=derbyclient.jar:derby.jar:derbytools.jar:derbynet.jar:........

        The problem seems to be derbyclient.jar coming before derby.jar.


          People

          • Assignee:
            Knut Anders Hatlen
            Reporter:
            Ole Solberg
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development