Uploaded image for project: 'Derby'
  1. Derby
  2. DERBY-3993

With IBM 1.6 T_RawStoreFactory fails with There should be 0 observers, but we still have 1 observers on Win 2K

Agile BoardAttach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 10.5.1.1
    • Fix Version/s: 10.5.3.2, 10.6.2.4, 10.7.1.4, 10.8.1.2
    • Component/s: Test
    • Environment:
    • Urgency:
      Normal
    • Bug behavior facts:
      Regression Test Failure

      Description

      On Win2K T_RawStoreFactory fails consistently with
      java version "1.6.0"
      Java(TM) SE Runtime Environment (build pwi3260sr3-20081106_07(SR3))
      IBM J9 VM (build 2.4, J2RE 1.6.0 IBM J9 2.4 Windows XP x86-32 jvmwi3260-20081105_25433 (JIT enabled, AOT enabled)
      J9VM - 20081105_025433_lHdSMr
      JIT - r9_20081031_1330
      GC - 20081027_AB)
      JCL - 20081106_01

          • Start: T_RawStoreFactory jdk1.6.0 2008-12-17 09:37:49 ***
            2 del
            < – Unit Test T_RawStoreFactory finished
            2 add
            > There should be 0 observers, but we still have 1 observers.
            > Shutting down due to unit test failure.
            Test Failed.

      I have seen the same failure on Linux and Windows XP intermittently with IBM 1.6.

        Attachments

        Issue Links

          Activity

            People

            • Assignee:
              mikem Mike Matrigali
              Reporter:
              kmarsden Katherine Marsden

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment