Derby
  1. Derby
  2. DERBY-3914

Failure in OnlineCompressTest with FileNotFound exception on 10.3 using weme 6.1

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 10.3.3.0
    • Fix Version/s: None
    • Component/s: Store
    • Labels:
      None
    • Environment:
      weme 6.1
    • Urgency:
      Normal
    • Bug behavior facts:
      Regression Test Failure

      Description

      I saw this failure with 10.3.3.1 - (704293) (October 13,2008) with weme 6.1

      2008-10-15 00:02:22.828 GMT Thread[main,5,main] (XID = 1526267), (SESSIONID = 0), (DATABASE = wombat), (DRDAID = null), Failed Statement is: create index TEST6_idx_keycol on TEST6(keycol)
      ERROR XSDA4: An unexpected exception was thrown
      at org.apache.derby.iapi.error.StandardException.newException(Unknown Source)
      at org.apache.derby.impl.store.raw.data.StreamFileContainer.load(Unknown Source)
      at org.apache.derby.impl.store.raw.data.BaseDataFileFactory.addAndLoadStreamContainer(Unknown Source)
      at org.apache.derby.impl.store.raw.xact.Xact.addAndLoadStreamContainer(Unknown Source)
      at org.apache.derby.impl.store.access.sort.MergeSort.createMergeRun(Unknown Source)
      at org.apache.derby.impl.store.access.sort.MergeInserter.insert(Unknown Source)
      at org.apache.derby.impl.sql.execute.CreateIndexConstantAction.loadSorter(Unknown Source)
      at org.apache.derby.impl.sql.execute.CreateIndexConstantAction.executeConstantAction(Unknown Source)
      at org.apache.derby.impl.sql.execute.MiscResultSet.open(Unknown Source)
      at org.apache.derby.impl.sql.GenericPreparedStatement.execute(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedStatement.executeStatement(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedStatement.execute(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedStatement.execute(Unknown Source)
      at org.apache.derbyTesting.functionTests.tests.store.OnlineCompressTest.createAndLoadLargeTable(OnlineCompressTest.java:295)
      at org.apache.derbyTesting.functionTests.tests.store.OnlineCompressTest.test6(OnlineCompressTest.java:1385)
      at org.apache.derbyTesting.functionTests.tests.store.OnlineCompressTest.testList(OnlineCompressTest.java:1505)
      at org.apache.derbyTesting.functionTests.tests.store.OnlineCompressTest.main(OnlineCompressTest.java:1520)
      Caused by: java.io.FileNotFoundException: E:\cloudtst\jartest\JarResults.2008-10-13\weme6.1_derbyall\derbyall\storeall\storemore\OnlineCompressTest\wombat\tmp\T1224028764517.tmp
      at java.io.FileOutputStream.<init>(FileOutputStream.java:70)
      at java.io.FileOutputStream.<init>(FileOutputStream.java:47)
      at org.apache.derby.impl.io.DirFile.getOutputStream(Unknown Source)
      at org.apache.derby.impl.store.raw.data.StreamFileContainer.run(Unknown Source)
      at java.security.AccessController.doPrivileged(AccessController.java:240)
      at org.apache.derby.impl.store.raw.data.StreamFileContainer.privGetOutputStream(Unknown Source)
      ... 16 more
      ============= begin nested exception, level (1) ===========
      java.io.FileNotFoundException: E:\cloudtst\jartest\JarResults.2008-10-13\weme6.1_derbyall\derbyall\storeall\storemore\OnlineCompressTest\wombat\tmp\T1224028764517.tmp
      at java.io.FileOutputStream.<init>(FileOutputStream.java:70)
      at java.io.FileOutputStream.<init>(FileOutputStream.java:47)
      at org.apache.derby.impl.io.DirFile.getOutputStream(Unknown Source)
      at org.apache.derby.impl.store.raw.data.StreamFileContainer.run(Unknown Source)
      at java.security.AccessController.doPrivileged(AccessController.java:240)
      at org.apache.derby.impl.store.raw.data.StreamFileContainer.privGetOutputStream(Unknown Source)
      at org.apache.derby.impl.store.raw.data.StreamFileContainer.load(Unknown Source)
      at org.apache.derby.impl.store.raw.data.BaseDataFileFactory.addAndLoadStreamContainer(Unknown Source)
      at org.apache.derby.impl.store.raw.xact.Xact.addAndLoadStreamContainer(Unknown Source)
      at org.apache.derby.impl.store.access.sort.MergeSort.createMergeRun(Unknown Source)
      at org.apache.derby.impl.store.access.sort.MergeInserter.insert(Unknown Source)
      at org.apache.derby.impl.sql.execute.CreateIndexConstantAction.loadSorter(Unknown Source)
      at org.apache.derby.impl.sql.execute.CreateIndexConstantAction.executeConstantAction(Unknown Source)
      at org.apache.derby.impl.sql.execute.MiscResultSet.open(Unknown Source)
      at org.apache.derby.impl.sql.GenericPreparedStatement.execute(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedStatement.executeStatement(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedStatement.execute(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedStatement.execute(Unknown Source)
      at org.apache.derbyTesting.functionTests.tests.store.OnlineCompressTest.createAndLoadLargeTable(OnlineCompressTest.java:295)
      at org.apache.derbyTesting.functionTests.tests.store.OnlineCompressTest.test6(OnlineCompressTest.java:1385)
      at org.apache.derbyTesting.functionTests.tests.store.OnlineCompressTest.testList(OnlineCompressTest.java:1505)
      at org.apache.derbyTesting.functionTests.tests.store.OnlineCompressTest.main(OnlineCompressTest.java:1520)
      ============= end nested exception, level (1) ===========
      Cleanup action completed

        Activity

        Kristian Waagan added a comment -

        Resolved as Cannot Reproduce. Please reopen if the problem is seen again.

        Kristian Waagan added a comment -

        Triaged July 3, 2009: Assigned normal urgency.

        Kathey Marsden added a comment -

        Should we close this Cannot Reproduce? I think it was just seen the one time.


          People

          • Assignee:
            Unassigned
            Reporter:
            Kathey Marsden
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development